IKEA Tradfri lamps

I have one switch which operates two lamps with tradefri 27E bulbs. When I pair them with homey then both are reacting but when installed only one still reacts via Homey app.
Is there a solution for this issue so that two lamps react on Homey app?

Giving some more detailed info than this may be handy.
What kind of switch? wired or wireless?
Are they physically wired sockets (so bulbs power off physically)
Are the bulbs under constant power?
Switching by flow or by direct connection?

The switch is a physically wired switch that powers off and on the two bulbs in two different lamps . So bulbs can be powered on and off physically. I linked the two Tradfri bulbs (physical switch turned on) to Homey. During installation the two bulbs reacted as expected. They where both flickering on and off. After installation I used Homey to switch the two bulbs on and off (when the physical switch was on) both with the `homey button and in a flow. Unfortunately, only one bulb was reacting to homey.

For starters: you shouldn’t physically turn on/off smart bulbs, they are intended to be “always-on”. Physically turning them on/off will cause issues with your Zigbee mesh, and could be detrimental to their lifespan.

Aside from that: do you have a flow with two separate action cards, where each card would switch a particular bulb on/off? If so, try adding a delay of a few seconds to the second card.

The bulbs are on one physical switch that is always switched on. I can;t make a distinction between the two bulbs. I tried to switch of via `Homey flow twice with few seconds in between to see if one is switched off the second card will switch off the second bulb behanind the same physical switch

Unfortunately this didn’t work

But you can switch the second bulb on/off via Homey? You have to rule out if it’s the flow that’s causing the problem, or the overal connection between Homey and the second bulb.

As I mentioned in my reply one hour ago. During installation both bulbs are reacting correct (flickering). So they are recognised. Only after the installation only one reacts to homey flow or the homey individual button. I also installed one bulb in one lamp. that worked, Then I installed only one bulb in the other lamp, then that worked too. But both installed behind the same physical switch does only work with one lamp.

So the problem isn’t the flow, but the pairing of the bulb with Homey (otherwise the individual button would have worked). Did you try removing and adding the second bulb again?

Are both lamps when installed, really close to eachother?? if so… can you try to put one lamp in a different place with more space between the 2 bulbs. and then try your flows again.

Also, with Tradfri bulbs, it is best to switch already paired bulbs off physically before adding the next one. Specially when they are close to each other.

the lamps are 5 meters from each other.

With the same physical switch how can I add the second bulb without removing the device first where ì also loose the connection with the first bulb again

Simply unscrew it?

If I unscrew and add the second bulb then the first one doesn’t react anymore only the second then reacts. I think this is not solvable and a flaw in homey handling. Also in advanced setting nothing to set to overcome this issue

Just for the correct understanding (u say a lot of different things all the time) did u reset the bulbs by powering off/on 7 times? And then, with just 1 bulb connected to power, added that bulb? Then remove that very same bulb from power and, after that bulb was removed, added the 2nd bulb after a reset of that 2nd bulb? And, after that, connect the first bulb to power again so both have power?

How many Zigbee devices do you have connected directly to Homey?

I offered you a simple way to try to solve it and pointed you to a known issue, but if you don’t want to hear or try it, well, good luck.
Maybe first try to understand what you are doing, ask the correct questions including the correct information and then after that start to blame Homey. In this case unfortunately imho it’s to blame to the end user.