My flow will only trick one out of three bulbs


I have a Homey Pro and have created a flow that will turn my three kitchen lamps on when on/off on the connected IKEA dimmer is pressed. It’s a very simple flow, but only the first bulb I paired are turning on and off. I’ve tried adding them as individual lamps instead of turning off the room, but no matter what I do it will only turn one bulb off.

I’ve even installed the Groups app and tried turning the group off, but it’s still only one lamp being affected.

What could be wrong?

Guess you tried everything you could do on Homey.
In Homey you should add a 1 second delay extta for each extra light.

Is you use the IKEA Trådfri hub you could create a group in the hub and switch that.but than you create a second zigbee network.

Please report your issue at Athom support.
I hope this brings it to the needed priority to fix this issue.

Is it possible for you to switch on / of the other two lights without a flow, from the device list?

I can turn on and off all three bulbs at the same time, when I trigger the flow in the app.

When you trigger the flow manually, the dimmer button isn’t transmitting. Maybe the transmissions from the button are interfering with the communication with the lights? Have you tried the delays Dijker mentioned?

Could it be other flows accidentally linked to the same button are counteracting your commands? e.g., if you disable the flow, turn the lights on manually and press the button, do the lights go off?

I have tried setting a 1 sec delay on all lamps so it takes a total of 3 seconds to turn them all on, but the problem remains.

Have you tried a flow that triggers on the button press and sends you a notification? It sounds like the button is directly connected with that one bulb, and not (correctly) with Homey.


Yup, I tried that to troubleshoot and it doesn’t send a notification.

I tried pairing a completely new Trådfri dimmer and that connects without problems and can control all three bulbs. I’ve reset the other Trådfri dimmer by pressing the link button 4 times, that should be enough, right?

I can’t remember exactly how the remotes can be reset, but it may be necessary to also reset the light bulbs if they are paired with the remote.

1 Like

The way I’ve understood it is, that pressing the link button four times, deletes the previous pairing as well as entering pairing mode.

If it works, it works :smiley: