Homey's complete refusal to acknowledge Apple devices

I assume you already sent a support request to Athom about this?

Yes and they’ve acknowledged there’s a problem but just told me they have no idea when (if) it’ll be fixed.

I understand your frustration and both should work.
Even if you have already written that you have tried everything, maybe you can still post some screenshots?


  • Settings of the Homey smartphone app (Settings → Homey)

Homey smartphone app

  • Settings of the presence notification in the timeline (Home → Timeline → 3 dots → Presence)
  • Settings in the “My account” area (More → Account)
    Please make sure your email address is unrecognizable!!!

Please also check that the location is correct (More → Settings → Location).

As an alternative to the internal presence detection, you can also use additional iPhone apps in the meantime, e.g:

  • Homey App Location and Presence in combination with the Owntracks iPhone app
  • Homey App Connect Life360 in combination with the Life360 iPhone app
  • Homey App HomeKitty with the Apple Home/Kit
  • Locative: Geofence and Beacon with WebHooks
  • Geofency (costs) with WebHooks

The advantage of some iPhone apps in addition to Homey’s build-in presence detection is that some apps allow you to change the geofence area. In the Geofency app e.g., it’s possible to use additional functions, e.g. a WebHook should only be sent after a certain time within the geofence area. For example, if you only drive past your home, the “Coming Home” mode is not activated.

I’ll take a look and report back. Cheers.

Interstingly I thought I’d give it a go om my M1 macbook and it (The push notifications at least) work!!! But still nothing on either of the ipads or the iphone 15 and they are all set up the exact same!!!

So…things get weirder. I went to the homey app-timeline-three dots- push notifications and I can’t turn it on!!! (This is the ipad) the iPhone doesn’t have the three dots!!! So I can’t check further… grrrr

The non-existence of the three dots is probably because of the kind of user (guest or resident). In my testcase it only looks available for the owner-role.

So probably this option (3dots for timeline in app) is part of “System Updates” Like mentioned in https://support.homey.app/hc/en-us/articles/360012615814-Adding-managing-removing-user-accounts-on-Homey

Also when as owner you want to chane the Push notifications settings for presence, it says: "Push notifications for Presence are only sent to the owner of this Homey. It appears so for every change on the timeline made possible by the settings.

@Graham_Kirkman, did you send a notification by use of a flow? Like


Is Then-card; choose message and user and just “Test”.

Oh yes…

Hello Graham,

I have got more or less the same problem as I stated in
“Home / away 2nd iPhone” …
Still no solution despite all the kind attempts to help me by the forum members.
I sent a request to ATHOM and waiting for reply.

Damn. Back to square 1

We’re.in the same boat mate…

This is what I get when I try

Can you attach a card to show error? Something like:
And share the error?

Hello. This comment is probably annoying to some of you but we have never had problems with presence or notifications with the iPhone, when we follow some basic rules. Applies to HP19 and HP23. Home/away must be switched on. Location, Homey app setting and system settings must be correct in iPhone. Mobile data must be switched on and last but not least, the Homey app must NOT be closed. And as long as you visit the Homey app regularly, everything works as it should. (And we have no VPN client in use).

Here you go. Cheers
Screenshot 2024-04-22 at 17.20.38

Not annoying at all. Quite informative. and as for your list - Yup, all done. Still doesn’t work

I stumbled upon the next post:

1 Like

Yeah, did that. Still nowt!!!

That worked for me too. It’s a bit tricky and non-intuitive as you have to select your Homey first - and after that - select it again, even though it has already got a checkmark. In other words, you have to select it twice!