Homey Pro not detecting LG TV Active/Inactive correctly

I have a LG TV OLED77C16LA and my homey can see it, and I can control it from the Homey app, but for some reason Homey doesnt detect correctly when I turn the tv off from the remote and still sees it as active.

I wanted to create a flow depending on if the tv is on or off, but now I cant do that.

I tried doing the same in HA and it detects the tv correctly, so I am sure that the problem must be with Homey somehow.

Any ideas?

Does anyone have any idea how I can make Homey detect the on/off correctly?

Have you tried turning off the Quick Start function?

Do you use the Homey app store version?
The community app store version works 100% fine with my webOS tv set:

Thanks for the tip, I wasnt even aware of the community store, I installed the webos plus app and it works great now, thanks a lot.

1 Like

As I understand LG WebOS plus it not easy to install as HCS seems to be closed (not counting in the CLI workaround). Does anyone get the official apps for LG TV to work? What I would like the flow to do is “When” LG TV is active “And” Luminans is less than “Then” turn on choosen lights

HCS is being rebuilt, but it’s unsure when it’s operational.

Any ideas on how to minimize the latency(when homey detects TV on) when using the remote to power on the TV?
I have the LG web os app and added the TV as IR remote.

LG web OS, or LG WebOS Plus app?
I just checked with the LG WebOS Plus app in a flow, it detects On or Off, when I use the IR remote, within a few seconds. I think it’s pretty quick.

Oh and some really good news, the new homeycommunity.space store is in test phase now, and among some others, the LG WebOS Plus app by Max van der Laar is installable
( @spelevinken , that was pretty quick :slight_smile: )

(You’ll have to create a separate account btw.)

LG WebOS Plus app:
When the HCS is up and running @ your Homey, install it from the store inside the app (via app settings)

I get OK with downloading the LG WebOSPlus in Homey Pro. This is were I get lost (me being new to this). Where do I see the app and can include it in advanced flows?

And you downloaded the HCS app installer, and installed the HCS app using a Windows or Mac machine?

I don’t know what that means :hugs:

I dont have HCS, just the offical app. The latency is from 30sek to serveras minutes :see_no_evil:

App downloaded, run as administrator and installed. As i mentioned I get the OK when downloading WebOS but I can’t see it in homey. I think maybe I am doing something wrong. Am I supposed to use the HCS-app when installing WebOS?