Homey Offline

Hi,
Very often i cant log into homey, it says.

Homey Offline

I seems homey is freesing for some time.
Flows are not working.

Is ther a way to debug this?
What is cousing this?

THX!

image

1 Like

Got this to allot, but only when i am actively working and editing and testing my flows.

I have the same problem. Need to restart Homey (very annoying)

I have the Homey now for a week and is now structural offline, even re-power and an other power supply will not help. What could be the cause and how to debug if I can’t connect. Any suggestions to proceed?

After searching and searching in all kinds of forums I think I know the issue for my case. I am using a local dns on my synology nas, this is sometimes unreachable because of some load on the nas which causes that the dns is not reacting. Now is the question where can I set my network settings manually? Turn off the local dns is in my case no option.

Hi Cnoork,

Since one year i have the same problem. what i noticed that when Athom is busy with new releases to test i get the disconnects. I have several trouble tickets made but no one can find the problem.
I dont have a DNS running on my synology.
I use the app candy to reboot my Homey every 6 hours.

I know with me it is probably my local dns, moved now the homey to other network and look if I have then still the problem, in that network it will get the providers dns. If the problem is gone then the cause is probably that the second dns is not used as fallback. I have with my laptop sometimes the issue for my local systems but never for the internet because I have configured the google dns as fallback in the dhcp config.

==Update==
Unfortunately, the network with the dns from outsite did not help 100%. A restart from the Homey did help but is not the solution where I am happy with…

Hi cnoork,
is this issue already solved ? Do you still use candy for rebooting your homey ?

Hi, the issue is solved.
homey is always online.
I still use candy to reboot homey every night at 3:15, this might not be needed anymore but i it works fime.
Homey in V2 works super now.

Thank you! I use V2.0.4 and the same issue happend to me already 2 times in 4 days. Therefore I am thinking about the same workarround until I find a root cause or Athom fixes it.

Hi cautje,
how did you manage to run candy on Homey V2 ? It says it is incompatible, so I am not able even to install it…

Do u have the heimdal App? I had the same issue always after the heimdal App Update. Since i deactivated heimdal i have no offline issue any more. @DaneedeKruyff for Ur attention. I know IT from me and @undertaker. Since i have disabled heimdal there is no offline issue. Maybe @Zdenko_K too. But He doesnt say anything…

Reading this whole post I see a lot of assumptions and mixed up conclusions are made. I can not see how Heimdall (on itself) can cause Homey not being online. Heimdall does nothing more then ‘sleep’ waiting for events to be pushed to it and when that happens it will act on it. We do know there is (/has been?) a memory leak in recent firmware versions which may be the cause of Homey being offline. I have not received any crash reports with memory or CPU warnings since after 2.0.1 has been released (before I received many) so there is no reason for me to believe there is an issue with Heimdall.
So for now I see your case as an incident and wonder if it’s really Heimdall that’s causing the problems you are experiencing.

(For the rest of this topic, I think Cautje is running 1.5.13 so yes Candy works for him. Candy is not needed for rebooting since 2.0.5 because there are cards for that, you need to enable power user in the experimental settings. Homey V2 does not use DHCP provided dns servers but preconfigured ones by Athom because they do a nasty dns rebinding to get local https working. This is actually the thing that in my opinion is the cause of many ‘offline issues’ )

Hi @Mrwitchblade,

I do not have Heimdall App installed, what I just recently installed was Heating Scheduler, but I am not sure that this could cause offline issue…
What was proved is, that Homey was accessible inside the LAN, so it lost connection to cloud only. I was able to log-in locally. Therefore, I will just review my settings of the router, even I do not believe, something is wrong (as all other devices are working properly with nornmal access to WAN).

While writing this answer @DaneedeKruyff answered, so it explains in more details a possible root cause. Maybe we have simply to wait for a fix in the next stable version. It is still experimental.
And @DaneedeKruyff, thank you for a hint with existing cards for rebooting in Homey V2.0.5. I am still on 2.0.4, but I can try to update to 2.0.5 and try to use those cards as a power user.

Hi Guy’s i ame running 2.0.5 with candy and i ame a verrry happy Heimdall user.
Candy reboot is still working, just checked it. Maybee because i already had it running before 2.0.
My home has a running more apps than advised but is running verry smooth now.

That must be it, compatibility in Candy’s app.json shows "compatibility": ">=1.5.0 <2.0.0", so running it when installed on a V1 version works but installing it on V2 is not possible.
Thanks for clearing that up, glad you like Heimdall :slight_smile:

:+1::+1::+1:

Hi @DaneedeKruyff,

I am finally on 2.0.5 version and I enabled power user, so I am able to reboot Homey.
Currently, I made a flow to check the connection from Homey to cloud by the application Network Check that checks the connection every minute. If the connection is lost 5 times (I use a counter) Homey reboots.
Another flow resets the counter after regaining the connection.
Hope this will work. There was no offline error yet.:+1:

I also reboot by homey power user and not by candeapp anymore.

Great!
Could you post screenshots of your flows to help others and future reference?