Homey location incorrect

I noticed that homey reports me not at homey.
I check the location in the settings and here the location of my homey is more then 40km difference between my real location.

How can i a just the location of Homey so the location is correct again.

Disable the find Homey’s location automatically
And move the map below the Pin

Thx, i tried that already but that does not work either…
Homey still sets me as away, until today this worked perfectly for years but suddenly homey is setting me on away due to lcoation problems.

But first Homey’s location should be correct

That way it is never going to work.

Have you already left home and walked up to 500m away before reporting it doesn’t work?

Again my homey location is incorrect, my personal lcoatie is correct, so when i move 500 meters from my current location i am 40km and 500meter moved from my homey …

The problem is that for me unknown reasons my home location is incorrect and when i set this manually to my address (there is no save button) and go out of homey and back into it after 5 minutes the position is back to 40km away…

So that Homey reports i am away is correct when it uses the incorrect location of my Homey address, but there is no way to correct this home address.
I have homey now for several years (aprox 4to5 years) but i never had any problems with my Home adres…

Have you followed this step?

yep, in the map i selected my home address and went 1 menu back.
After a while i checked the settings again and the map is back to 40km from my real address i selected…

That was not my question

This can help: Try to move the pin to f.i. Ireland, leave the settings page, and then go back to the settings and move the pin back to your home location.

And this setting is key (as Geurt tried to explain):

Have you disabled:

find Homey’s location automatically

And what version Homey firmware and mobile app and platform do you use?

both latest

Latest not found

As I guess you never know if it is the latest…
Fe
This?

A newer version is not available in the play store at the moment.

That’s correct,

What is your user role when changing the setting ? Owner? Manager? User? Guest?

owner

What is the result of first command

Homey.geolocation.getOptionMode();
// Homey.geolocation.setOptionMode( { value : "auto" });
// Homey.geolocation.setOptionMode( { value : "manual" });

when run from Homey Developer Tools ?
With the last line you should be able to switch it to manual, but I think there is a bug in the App you should report to Athom.

I once described the issue with the Geo IP database,

So probably the Geo IP database (or SSIDs) from a service provider is off…
It updates the Geo info reported by Mobiles with GPS in their IP of SSID Database.
Maybe someone moved an AP to another location and when Homey Sees that AP now and it gets an old Location from the online database.

I have seen my Laptop once reporting my location, jumping from Barcelona, to Tokyo, Las Vegas. 5 times around the world in less than a hour.

Great technology but not at an Microsoft of other Tech company seminar traveling around the world the complete circus of AP and people reporting these AP / SSIDs. Next time these ar enot reported as there is no GPS if you connect.

Pretty sure the issue Homey was plot on a wrong location on earth was an result from a “Positioning” database update …

Same problem here. Tried everything I could find on the internet.

I have the same problem with my Homey.
Version is: 6.11.0.854
Homey-App: 6.11.0

On automatic mode Homey set “Paris” as our location, but we are living near by Strasbourg (500 km distance).
Only in manual mode I can configure our real location.

Advice is to keep it that way, your Homey itself doesn’t move much most of the cases, does it?
AND the Home/Away function works way better @ manual mode.

1 Like