Goodwe solar panels inverter: who can help?

I have installed the beta-version of Diederik’s Solar Panel app with my Goodwe converter. However, I can’t create a new inverter. After typing my goodwe username and tapping ‘connect’ it doesn’t do anything. @Christo, I noticed you had the same issue last month.
Have you been able to find a solution?

1 Like

Unfortunately I haven’t.

GoodWe migrated to a new portal and the endpoint that the app uses is broken.

The issue is tracked here:

@Diederik any idea about progress in the Goodwe field?

Someone took the initiative to build an implementation once v3.0.2 is released. Let’s wait it out, you can track progress here:

hi @Diederik any news on when 3.0.2 is released? From the release notes on it seems that 3.0.2. has already been released, right?

Athom still needs to approve the update, so it’s up to them.

Hi @Diederik was the update already approved by Athom? And any idea how soon the Goodwe / sems integration will be available again?

I unfortunately do not know more than is stated in the GitHub issue I linked here earlier.

Hi, is there any progress on the Goodwe connection to be reported? Thanks.

Yes, please install and report back with your experiences.

looking forward, but coincidence or not today not able to login to the SEMS portal due to authentication failure (even after pwd reset). Will try later again.

Hi folks, also super keen for this functionality for the SEMS connectivity. Have also tested the 4.0.2 version - login is successful to SEMS, but on the following screen received the error in the screenshot. Diederik if I can help test in any way happy to help out.

PS. Will the functionality also feature the SOC tags?


Hi @Diederik , I’ve installed 4.0.2 successfully, then also succeeded in addin my (2) Goodwe inverters (I had to enter my SEMS credentials). But then I got a message when I click on the converter’s tile saying something like ‘only absolute URLs are supported’. What did I do wrong here?

EDIT: despite the errors I mentioned yesterday seeing within Diederiks app, the app was still able to fetch the generated solar power from SEMS (from both my inverters, within the same SEMS account). So my ‘daily solar revenue’ flow is running again! Me happy! :slight_smile:

Sounds like there are still some bugs (it’s a test version after all). Wondering whether these stem from an instable GoodWe API or the app itself.

@DaveCush77 Could you try the pairing process again? I had the same issue once, but it worked on a second attempt. Will look into fixing it.

I’v tested 4.0.2 for 10 days now. At first attempt got same error @DaveCush77, but with second attempt it worked instantly without errors or warnings. For me it helped to login to the SEMS portal and do a forced logout (just click on ‘logout’) to make sure there were no concurrent sessions.

Since then it worked perfect, except for some time a few days ago, when the SEMS-portal itself experienced login-issues. The tile gave a warning and did not show any readings. The app/tile recovered itself after a while.

Measurements from insights are in line with the figures in the SEMS portal, so that’s ok. I’ve made some flows based on the readings (some lights on/off and notice of daily revenue).

I only have 1 converter, so not been able to test the situation with multiple converters in 1 account.

Except for the issues with the initial pairing, I think it is stable enough for release ?

Keep up the good work @Diederik !

@Joost_van_Kempen Great, thanks! Did the tile give a clear error message? I will first try to figure out a fix for the initial pairing problem, or at least reproduce it.

When connection to SEMS failed, the tile greyed out and gave a red exclamation mark similar to a light or other device that is offline. no code showing or other user-unfriendly messages. For me, that’s the expected behaviour.

Another plus for me is that I never had to re-enter my credentials. Connection restored itself and in 10 days I never re-paired or anything

Hi JonE, care to join your goodwe inverter flow related flows?

Sure. Here it is:

1 Like