Get push when doorsensor is activated at a sertain time


Have installed some Aqara door sensors but do not understand how to get a flow together the way I want it.

I want that if the door opens between 22:30 and 08:30 (at night) I will get a push to my mobile. If the door is opened at other times, I will not get a push.

However, I also want to get a push when the door is opened if no one is home, even if this happens during the day.

Would like this to be solved without me having to have my gps on on my mobile all the time.

Grateful for help.

This is quite simple - just one “IF” (opened) “and” time is “NOT” between “daytime”. May-be, only trick here is to select initially “Date & Time” - “Time is between” (and after card is put into “and”, then from “…” select “Invert”).

The “no one is home” - another flow. And also little bit more self-study (or possibilities). By simple way - again “sensor triggered” AND card “Presence” - “Nobody is at home”. Also it’s useful to add AND “is daytime”. Unless You get two pushes (from both flows).

About self-study i was talked because here is looooot of threads about presence detection. Smells, someone’s GPS anyway does not working allways, someone’s phone changes MAC, some… but this is not a sensor-pushalarm problem :wink:

If you don’t need different push notifications it’s possible with one flow:

— The contact alarm is activated

— Time is not between 08:30 and 22:30
— Someone is at home
— No one is at home

— Push notification


Thanks for your replys guys. I will try this last flow and see if it workes.

About when I’m not at home, I have to do this in “presence” right? Does this mean that I always need to have my GPS activated on my phone? Or how does Homey knows noone is home?

Is is possible to make it like when my phone disconnect from my wifi instead?

Without GPS but with WiFi, you can consider the Smart Presence app; this checks your phone connection to your WiFi and thus “your” presence.
You can use these flow cards (and the inverted versions)

So if I put it like this, should it work then?

— The contact alarm is activated

— Time is not between 08:30 and 22:30
— Someone is present (Smart Presence)
— No one is present (Smart Presence)

— Push notification

About Smart Presence app, do I need to do anything for it to work with my wifi or does it just work? Do I need to connect my router/mesh with Homey? I have TP Link M9 as mesh.

EDIT: I have added me and my partners ip adress in smart presence now.

EDIT 2: Just tested this, opened my door and got a push thou I’m home and it is daytime. Tried both “time is between” and “time is not between” but I get push at both wich I don’t want.

Are you sure the presence with the Smart Presence is working as it should? When I used the Smart Presence app I had several fault presences because my iPhone disconnected von time to time from the WLAN.
It should be very tricky to set the settings in the in Smart Presence app that it work flawless. Another point you need to use fixed IP addresses for the smart phones.

No I’m not sure that it’s working properly. How do I check that?

About giving me a push or not with the flow about the time between, that shouldn’t have anything to do with presence or not, I’m I right? It’s not working anyway.

Haven’t found in my router how to fix the IP but this far it seems that the ip is the same even if I disconnect to wifi.

It’s a long time ago when I used this app, so I would please you to inform you in this thread:

I was not satisfied with the app. However, it probably has less to do with the app, but more with the home WLAN.

You’re wrong. Of course has it something to do with the presence of you and you’re wife. The presence is queried as a condition in the And… section.

Try this flow if it works:

— The contact alarm is activated

— Time is not between 08:30 and 22:30

— Push notification

Ok, will check the thread.

That flow did work!

Isn’t that the same as

— The contact alarm is activated

— Time is between 22:30 and 08:30

— Push notification

What does it mean exactly? Did you get a push notification or not? And what time was it when you tested the flow?

In theory yes, but flows sometimes didn’t work when the time card „The time is between“ starts at one day and ends at the other day. So the better and safe way ist to use „is not between“.

I got a push and I tested it now at 20:00.:slightly_smiling_face:

Just the presence thing to figure out then.

Aha, when it changes the day, good to know.

I mean I didn’t get a push at 20:00.
Tested just now at 23:10 and now I got a push.

So this works as I want right now🙂

Just set a static ip for my phone in my router.
By disable my wifi, would it be simulating that I’m not at home and by that tigger the push to my phone? Doing this between hours 08:30-22:30?

If you use the card „No one is home“ card in the And… section, you have to disable the WLAN on your wife’s smartphone too. Then it should work.

Hint: For the other community members it’s easier to help, when you share your flows. There are options to share a flow or just make a screenshot of the flow in the Homey Web App.

Nope, Homey doesn’t set you and your family away only by disabling WiFi.

you should set the user away,

If he uses only the cards of the Smart Presence app it should work. The SP app sets the card/device of their smartphones on and off, what means „Home“ and „Away“, depending if they are connected with the WLAN or not, so it should work.
But because I’m not 100 % sure, that’s the reason why I suggested that he has to inform himself how it works.

That by toggling the SP device card the Homey „Home / Away“ state will not be changed, that’s absolutely right.

I have set this up in the and…

I have a static ip for me and my partner in my router and added us as “device” in the SP app in Homey.

Tested by disable me and my wifes wifi but I don’t get any push.

Edit: Does it have anything to do with the defult delay setting in the SP app wich is set to 900 sec/15 min?
Does this mean that I have to disconnect from wifi at least that time and then if I open the door I will get a push?

I can update you with that the flow above works. I missed that I had to wait 900 sec for the flow to trigger.

Thanks for all your help guys :slightly_smiling_face::+1:t3:

Yes, I’m pretty sure that this is the reason.
Did you checked if you and you wife were at home or were away if you tested the flow? That’s really easy!



Not at Home


That’s the reason why I said you have to figure out how the SP app works.

Btw, why are you using “A specific user…” condition cards instead of “Household members home/not home”?

And why you don’t want to use GPS?

About household member, I didn’t think of that but I will try that instead :+1:t3:

About GPS I think mostly about battery drainage, avoiding that. Don’t use the GPS often so I think thats why.

Is using the GPS more reliable than the wifi state?