Fibaro Shutter 3 not supported yet?

Bought the Homey 2019 edition and tried to do the first steps with the Homey (Logitech Harmony was recognized) and bought a Fibaro Shutter 3. Cant get it paired. However, all 3 shutter devices in Fibaro App are NOT mentioning Version 3. So no support yet?

I submitted a request to the developers:

So it’s because it’s not supported. No generic solution possible until support will be there? Dont want to unplug the whole mess. Unfortunatly I cant use the switch right now. Would be enough but either I did wire sth wrong or even the switch does need the Fibaro 3 to be recognized

Ill be honest, I didn’t even check to see if it was a supported device, I assumed you had as it is your device.

If it is not, Yes it is likely that you could fix it yourself, simply by adding the new ‘productID’ to the code and then doing a CLI install.

Check out how to install an app using CLI and if you feel comfortable with the steps involved then we can look at adding the ID manually.

Or wait for Athom to update the code.


1 Like

I just ordered a Homey and 2 Figaro shutter V3 assuming it would work but it doesn’t? That is very disappointing!

If you can’t use the switch, you might have connected it wrong. Homey has nothing to do with the physical connection to the module.
What also might be a problem is the switch you used. I don’t know what type of switch the module is configured for by default.

1 Like

Thanks Jamie! That sounds like a solution I have been looking for. I will try that tonight when home.

But Id also be fine to wait for an update if I could still use the switch. That leads me to Fire69 :slight_smile:
Can you confirm the Fibaro Shutter 3 works behind a switch without being at least registered? Im sure the “physical feature” has nothing to do with Homey but Im not 100% sure Fibaro passes through the necessary signals if not even registered. If it should pass through no matter what wiring must be the issue.
Although I can’t see what could be wrong it it. But knowing it MUST work would be a good step forward.

I was 99.9% sure :slight_smile:
Until I read the manual.

Calibration using connected momentary switch

  1. Make sure:
    • the device is supplied,
    • momentary switch is connected to S1 and S2 terminals,
    the device added to the Z-Wave network,

So yes, it might be possible it doesn’t work without being added to a network (which would be completely stupid…)

I guess you should try Jamie’s solution then.

Hey Fire69,

thanks for looking into it. I’ll try Jamie’s solution in about one hour. I understood how to install apps using nodejs I guess. I hope I ll find out the rest. ProductID, where to put ProductID, whether overwriting Fibaro Shutter 2 device is the correct approach etc… I’m new to Z-Wave and Homey too.

I was thinking a bit more about this…

Not much can be done wrong to connect it if you would install it without the switch. L/N/2 outputs to the motor.
I would connect just those and then still try the calibration with the B-button:

Calibration using the B-button

  1. Make sure:
    • the device is supplied,
    • the device added to the Z-Wave network,
    • parameter 151 is set to 1 or 2.
  2. Press and hold the B-button.
  3. Wait for the LED to glow white.
  4. Quickly release and click the B-button again.
  5. The device will perform the calibration process, completing
    full cycle – up, down and up again

It says you need it connected to your z-wave and switch, but I doubt that should be necessary to control it this way…
If that doesn’t do anything, you can start experimenting with the app to try and pair it to Homey :slight_smile:

No joy, now Im in the driver.compose.json of the fibaro app. Id like to modify the json of the FRG-222 to allow the FRG-223. I want to change the given productid 12288 into the ID of the Shutter 3 but I cant find the ID anywhere

I am waiting for my Homey so I have no way to test it. On Smartthings does not work under FGR222 only under Fibaro Dimmer 2 ZW5.
I have four FGR-223 and there will be eight pieces soon so I would like it to work.

I made calibration by pressing S2 button three times for three seconds (you know this user manual = to put the blinds down, press and hold 3sec - 0.5 sec release the button - press and hold 3sec - 0.5 sec release the button - press and hold 3sec - release the button and now the calibration is triggered) without setting the parameters . Works on the dimming slider.


The RollerShutter 2 isn’t even fully supported yet…

What do you mean?

You can’t control Venetian blinds. Up and down yes but not the position

1 Like

I’m starting to get scared. No support for FGR222 positioning, no support for FGR223, no support for new Aeon nano shutter, no support (Homey 2.0 version) for the world’s best network zone player (LMS - Squeezebox - PiCorePlayer) I don`t know this migration from Openhab -> Smartthings -> Hassio it’s a good solution for me. :grin:
I see, however, that this is an ambitious project and everything will be fine after some time. :sunglasses:

Is that since 2.0?

You just bought your Homey. Didn’t you investigate this before buying it?

It’s so joking. All systems are not perfect. Openhab died completely after a few months of use, Smartthings does not work locally - Internet failure and coffee maker unheated in the morning (classic so needs 30min minimum). However, I must admit that it is stable. Hassio (I liked it the most) but all the roller shutters stopped working (“dead” message ffr223) After pairing again the same situation. But it’s great with Philips Hue. It always shows that something is turned on or off and it does it very well. Fibaro (a project from my country and very popular here) I just had to buy but when I started reading reviews from the last months, I changed my mind. Of course, I did some research a few months ago about Homey. I am very hopeful. I need something with commercial support and great potential. Something that supports rs232 (global cache - projectors, amplifier)), new roller blind controllers (I hope Athom will do it soon), has built-in infrared, supports Squeezebox (Homey already had such service in earlier version maybe 2.0.0 soon). It seems that the creators of this project are very committed and that gives this hope in this unstable industry. But it’s already offtopic …

Important! At Homey, I liked the web interface (such a beautiful and unique) but after submitting the order I found out that it will not be. This gave the opportunity to be operated on every OS. Maybe it will change and come back …

I tried faking it to be integrated as Dimmer 2 like you mentioned Bob! It was recognized. App said sth with slave. But afterwards there was no additional Device on device page. All those 3x3second stuff didn’t do anything either