Fibaro Heat Controller not pairing

Trying to add my new Fibaro Heat Controller, but it does not pair.
Already reset Z-wave network on homey and reset the Heat Controller.

Please advise

First remove it from homey (remove zwave device) even when its never be added before

Tried it, “No devices found, to be removed”…

even when you put it in zwave mode?

Yes even when I put it in Zwave learning mode, is there another mode?

I performed below:
To add the device to the Z-Wave network:

  1. Make sure the device is within the direct range of your Z-Wave controller.
  2. Set the main controller in (security/non-security) add mode (see the controller’s manual)
  3. Use the included key to quickly triple click the button on the thermostatic head.
  4. The LED ring will start blinking white.
  5. If you are adding in S2 authenticated mode, type in the device pin code (underlined part of the public key on the label).
  6. Waiting for the adding process to end…

Problem Solved.

Used the Reset procedure from the heat controller itself, through the menu according it’s documentation.

Hold the button untill Yellow, press 1 time, yellow blinks, blinking stops and then ready to add.


Hello Munnike !

I have problem with my Fibaro heater controler.
I cannot close my radiator (fibaro doesn’t push enough to close the circuit). I’ve tried calibrating manually but it doesn’t change anything.

Have you got same problem ? Solution for me ?

No not yet… :slight_smile:
I have to change my installation first, I am one off the 2% that does not have the correct connection on my heater. This will be fixed in januari after the holidays.

Will have to see if it works then.

Ok Thanks !

I’ve just returned my Fibaro Heat controler to get my money back. No good feeling about this product and for what I’ve saw on the internet, I’m not the only one. After testing some vannes (see my test here) I’ve realised that Eurotronic Spirit works wayyyyy better for half the price.

I got the Fibaro heat controller as well. It connected fine and also setting up with the homey was a breeze… BUT sadly enough my heat controller had a problem with the internal mechanism. It would only move for 2 seconds and then shut off. No full movement possible. The plastic shaft didn’t look allright. Returned it.