Fibaro Heating Controller not reacting

I have installed two Fibaro Heating Controllers and connected them to Homey, but they do not open the valve when I set a new target temperature.

Everything looks fine in the Homey app. There’s no warning that the connection fails and it’s apparently heating towards the new target temperature. But the heating controller does nothing.

If I use the physical handle on the heating controller to change the temperature manually everything works fine – The valve opens and the radiator starts heating.

Can anyone tell me what’s going on?


I have the exact same problem with my Homey and Fibaro Heat Controllers. No actions and no error messages when i try to set a new target temperature.

It is a know issue that the Fibaro Heat Controllers do not work properly with Homey. These devices use a technic called FLiRS which is used to save battery. As I understand it Athom disagrees with the way this is implemented in the Zwave protocol and therefor chooses not to properly support these devices with Homey.

Please do complain about it at the support team though as this has been an issue for over a year now and they have not come up with a working solution to support these devices.

What’s the firmware version of the heatcontroller?

Good question. Can I check that somewhere?

Is it possible to update the firmware through Homey? I have the same issue with other third party devices (Philips Hue for example).

Advanced settings in homey itself,

And updating is not possible due to protection from the manufacterers, I bought a second hand fibaro lite and updated the heat controllers now everything working fine

That’s really good to know! Thanks a lot! :slight_smile:

Where do you live, in the Netherlands you can sent them to Robbshop aswell

under 4.5 firmware the heat controllers react instantly

Under fibaro firmware 4.5 for the heat controllers everything fixed and working however battery life decreased to about 2/3 months iso 6. But I dont care now very nice fast control

Hi, any news regarding this issue? I have FW version 4.9 but I can’t change temperature through homey app.

Are you serious, I learn about it now when I have my heat controllers?

How did you downdate the firmware version? I tried looking for it online, I even bought a Fibaro Center Lite but there is nothing about changing the firmware…

I used the fibaro controller, unsubscribe from homey subscribe to the fibaro controller then you have to wait or restart the controller, and most of the time it will give you a warning new firmware is available. That worked for me.

It seems like the default firmware verson on my Fibaro is 4.9 - when I try to look at updates in the Home Center it says it’s up to date. Does that mean I should buy a controller with a lower version?

Thats a very good question, actually dont know the answer sorry. I can’t check as well as I sold the heating controllers.