Fibaro Heat Controller not reporting temperature

Is there something I can do to make the Fibaro Heat Controller report the temperature? It seems like I need to manually turn the knob (to wake it up?) for it to be reported. It then works for some hours before it goes silent again. Anyone else with similar issues?

I even bough a Home Center Lite from Fibaro to flash the latest 4.7 firmware on all my Heat Controllers, but the problem still occurs.

Is this the problem with FLiRS that I have been hearing about, which is incorrectly implemented by Homey?
I’m on the verge of selling my Fibaro Heat Controllers at this point, or replace my Homey. Any help would be appreciated! Attaching a screenshot that show how it just stops reporting temperature.

Hi, I don’t understand it. Mine update very well. Running homey 5? Latest fibaro app? External ble temp sensor? Temperature polling set to 300?

Hi, yes it’s Homey 5.0.2 and Fibaro 3.0.7. I didn’t use the external sensor actually, but I have it and will try with it again. Was hoping the one in the radiator knob would be enough.

Did you use any specific settings? I have tried disabling open window detection as well as setting enabled the increased receiver sensitivity (bit 1 and 4).

This could possibly be. Many users have problems with FLiRS thermostats.
But I also read that it could possibly have something to do with the firmware of the Fibaro Heat Controller.
But because I don’t have a Fibaro Heat Controller myself, I can not say much more about it.

Maybe it’s off topic.
But the Fibaro Heat Controller isn’t a FLIRs! :man_shrugging:

Even if it was ontopic, don’t spread wrong information around, the fibaro heat controller is definitely a FLiRS device.


I have the latest Fibaro HC firmware on it, the Fibaro Home Center told me it was “up to date” after I upgraded it to 4.7.

Seems promising with the external sensor connected so far, will see if it survives the night!

Sorry for the Fake News!
I was pretty sure that isn’t a FLIRs!

Mea culpa!

To find maybe some differences:
@birkedal, what is your FW of the Fibaro Heat Controller?
@Dennis_M, what is your FW of the Fibaro Heat Controller?

My firmware is 4.7 on the Heat Controllers, attached screenshot.

It has been running well now on three of my radiators, one with external temperature sensor and two without. Not sure what changed, it’s really odd. A fourth Heat Controller has not reported temperature for two days, so this one is still stuck.


Mine is on FW 4.7

1 Like


So there are no differences with the FW. :man_shrugging:t3:

I have sometimes problems with the commands from Homey to the FGT. I sometimes need to alter the FGT by hand to “wake” it up before responding to the homey. Furthermore it works most of the times. I would like to see it more stable but that’s also the case for the Eurotronic spirits.

I think FLIRS is still not supported by homey. Can anybody confirm this?

If FLIRS is still not supported I hope it will soon be. Polling instead of FLIRS consumes a lot more battery. And the wake up is still a problem

FLiRS is kind of “supported” with a workaround, it is pushed now as a device without battery, so Homey will just send the signal, but doesn’t take the variable timeout into account the FLiRS devices have, it isn’t polled though (by default), not sure where you read that, that wouldn’t do anything for signals towards the device either FLiRS is only beneficial for the battery device itself (receive signals), not the other way around.

One of my Heat Controllers have stopped reporting temperature again now, while the other three are working just fine. I don’t see any pattern for why it shouldn’t work on this last one, they all have the same version as well as some having a non-direct connection to Homey.

HC1: direct link to Homey, works.
HC2: one jump through a dimmer, works.
HC3: direct link to Homey, works.
HC4: direct link to Homey, DOESN’T work.

I submitted a support request to Homey, will update this thread with the reponse!

I have 7x HT and all of them have this problem and i don’t know what to do.
Some of them not reporting temperature for weeks!
I updated FW(4.7.2) on all devices using Fibaro HC.

Sounds like the same situation that I’m in, I reached out to Homey support but their only reply was to reach out to Fibaro support for help with their Heat Controllers. Homey told me they could not reproduce the issue, which means a fix is way off into the future.

Today I moved all my devices (Qubino dimmers, 4x Fibaro Heat Controllers and some controls and switches) to Fibaro Home Center 3 Lite. So far everything is working great, radiators are super responsive, seem to use less battery than before, lights seem more responsive. I will miss the nice Homey app, as well as their nice developer tools, but for now I just need a smart home that works with no fuzz. Maybe I’ll switch back one day once the quirks of Fibaro Home Center starts showing, but for now I’m all in. Wish you the best of luck!

Okay, here is my experiment.
I have two HC for a test.
1st HC connected to Homey
2nd HC connected to Fibaro HCL
Both HC connected to one external sensor.
First 10 hours, i received temperature updates for both 1st and 2nd HC.
After 10 hours, 1st(Homeys) stops sending any temperature updates.
2nd HC works fine and still send temperature updates.

The problem definitely with Homey z-wave protocol or with Fibaro app.
Tried to restart Fibaro app, nothing…

I would suggest to contact Athom.
I don’t have Fibaro HC or FLiRS devices, so it doesn’t make sense that I contact Athom (diagnostic report etc.).

Really nice test!
@fantross I included the diagnostic report from my Homey in the request to Homey, but I’m not sure if that helps them debug the issue. If @Klim is able to send one and include his or her test data as well, that would be really nice. The engineer that answered me was at home office and did not have access to the Fibaro Heat Controller that they tested with in the office. Still very strange that it’s such a hard problem for them to debug given that it happens so frequently on all my Heat Controllers.