Fibaro HC not keeping the set temperature

I have two Fibaro Heat Controllers (Z-wave) installed and connected to Homey. No matter how seem to set the temperature, manually or by using a heat controller app, the controllers jump back to 20,5 C a couple of minutes after being set.

Does any else experience this? And how do I avoid it?

It’s almost as if there is some kind of build in schedule in the controller that bypass Homey’s settings.

Any input? Thanks!

A range problem can you exclude?

One of the controllers is placed less than 1 meter away from Homey, so I wouldn’t think so…

Which Thermostat mode is set?
The Thermostat calibration is also done?

I can try the calibration. Where do I set the mode?

I don’t own a Fibaro Heat Controller.
But you should be able to set the mode in the device settings, like for a Spirit Thermostat.

Calibration didn’t make a difference, unfortunately.

I don’t have the possibility to select a mode. I just set the temperature directly.

Actually, I might have found the solution.

I was stupid enough to only test the setup using very low temperatures. It looks like the Fibaro controller doesn’t accept temperatures below 10 C. After I started testing higher temperatures, it seems to be working :unamused:

Thanks for your input though!