Fibaro Dimmer 2 (multiple) acting up

Hi! I’ve been using Homey for some years now (early 2016 model) and have also used a Fibaro Dimmer 2 for close to a year without any problem. It is installed in a closed box, no external hardware switch attached and is triggered only via Homey. As said, works like a charm.

I decided to upgrade and expand with 3 more Fibaro Dimmer 2 modules, combined with a ByPass as the lights are all LED and I considered it a ‘better safe than sorry approach’. As these dimmers were planned to go behind a wall switch, I decided to test these first before mounting them in and running into stuff, so I made a setup with a few cables and a small table-top lamp to check if it all worked.

I have:

  • Connected the Dimmer 2 module exactly like the one that is working,
  • Connected the Bypass accross the lightsource (screwed inside the plug),
  • Not connected the hardware switch yet to first test this.

When it powered up, it calibrated for 30-60’ish seconds. Then, when I toggle it on, it powers up, but after 1-3 seconds automatically shuts down again. Same when using the dimmer function, it goes to the indicated level, then powers down again.

What I have done/tested so far:

  • Swapped out the Fibaro DImmer modules (I bought 3, so I tested them all) - no change.
  • Swapped out with the other ByPass modules - no change
  • Made sure Homey was up to date, did a reset - no change
  • Made sure the Fibaro app was up to date, did a reset - no change
  • Double checked that the advanced settings of the Dimmer module had anything funny (similar to the one that is working correctly)
  • Did a hardware reset on the Dimmer modules - no change
  • Did a full reset on the Homey Z-Wave network, having had some trouble re-adding the old modules again, but made sure I really removed the modules via settings/Z-Wave.

Attached is:

  • Screenshot from the Fibaro Manual, with a highlight how I connected the modules

Any tips on solving this issue, or what may be causing this automatic powering down of the module? The light source is a plain 5W LED bulb.


In the normal 2-wire setup (with a switch), there’s a connection between N and Sx:

I wonder if this is required to prevent Sx from being a floating output, so it might be worthwhile to make sure that there’s a wire from N to Sx.

1 Like

That’s a must, indeed.

That is interesting, I will try that.

The other Dimmer 2 I have installed has a higher load connected (±50W) - could it be that the floating output is less of an issue then? That one works like a charm and is connected exactly the same.

Will try to connect the N on the Dimmer, thanks!

I had a similar issue last week when trying to connect 3 5W leds to the dimmer 2.
In my case, it turned out that calibration did not succeed, which was (only) indicated by the red status light on the dimmer 2 after the calibration process (no notification in the Homey interface).
Maybe a stupid question, but did you choose for auto-calibration with bypass?


I did not choose any setting, but by default I do believe it that is set to auto-calibration with bypass indeed.

In the Homey app you can choose the calibration type, the first choice is without bypass.

Finally took the time to check all this and provide an update:

  • When the Dimmer 2 is included into the network, the initial state for the ‘Auto Calibration Type’ is set to just ‘read’, the other 2 options are for auto calibration and those are not selected initially.
  • I have added a small connection between Sx and N, this has solved my problem. It appears that the output was indeed ‘afloat’ on this small load. Why this has never been an issue with the other Dimmer 2 I am using for close to a year now (50W load) I find equally puzzling.