Error on the Fibaro and Aqara app download

Hi there, just bought a Fibaro Double Switch 2 so i can control my Duco airvent with Homey.

Problem is, when i try to download the app to install it i get the following error: je hebt geen toegang om dit te doen. (translated, you dont have permission to do this)

Earlier i had the same problem with products of Aqara.

Anyone can help me with an solution?

Are you loged in as Owner of Homey?

Guess you are user.

Thanks, my brother did install the homey for me and made himself owner.

Gonna try to chance the ownership and try it again. Hope its solved.

It will still not work, when i try to install it now, it keep on installing…

Keep Zwave devices right next to Homey while pairing.
The first Zigbee devices too.
For end-devices (battery operated): Often you’ll have to keep pushing the pair button every 2 secs or so while pairing.

Here some zwave and zigbee best practices:

thanks for your help,

It was neceserry to be owner. after i chanced it it took 12 hours. but after that i could install the app. It worked.