Eglo Connect-z Remote 2.0 Wont Connect


I just bought two e27 eglo zigbee bulbs and a eglo Connect-z Remote 2.0.

I can pair the two bulbs just fine.

But when trying to pair the Remote, it finds the Remote in parring mode, but it keeps trying and says it’s taking to Long.
Finally it comes out saying pairing failed.
I tried pairing directly to the Eglo App which connects just fine, and updated the firmware to 2.7.3 which is the latest.

I have the homey pro running 10.3.0 Rc 7.

I have reset the Remote and tried multiple times without any luck.

Do any of you guys have some tips, have you succesfully done it?

Thanks :slight_smile:

Hej Rasmus, welcome.

Hint, while the remote is a battery operated device, keep it from going into sleeping mode, by pressing the pair button every other second during the pair process.

How? Do you own an Eglo zigbee hub as well? Just curious.

And please try to post in the appropriate app topic.
When searching for ‘app eglo’ I got this app topic as result:

You can also send the developer an email message, contact info is present at the app page @ store!

Thank you for welcoming me. :slight_smile:

Its my first post and i am quite new to this Forum, i Will try to be a little more specific when posting thank you for the heads up.

The Remote connects directly to the phone via Bluetooth and can be paired to groups of bulbs through there.

I have just tried your suggestion, still no luck. :frowning:

1 Like