[App] Eglo - Light up your world

Central Topic for Eglo App for Zigbee devices.
Also knows as AwoX Zigbee

This tread is not monitored by the Brand or Developer EGLO Leuchten GmbH
For Official support use the Email link in the App support (currently mailto:homey-eglo@drenso.nl )

Discover the smart world with EGLO and Homey!

Connect the wide range of EGLO Zigbee lighting devices and accessories (connect.z, crosslink.z and Smart Choice) with Homey to unlock the full potential of your products.

Adjust the RGB color, brightness, set your preferred white temperature and start creating your best automations. Control your environment with your app, your remote or your favorite voice assistant at the same time!

At this moment the App supports these type of devices


Reserved 2

I Asked the Developer:

Great to have an official App, is it possible to have Homey set a Flame mode on the Light Device?


Developer: Thank you for your review! Unfortunately we do not support Flame mode control over ZigBee, you will have to use the HomeControl app to enable that.

Has anyone experience to connect EGLO LED panels via Zigbee, so far they are not supported by this app?

I expect all Light devices are supported (only showing a bulb)
but would suggest to ask the Developers as mentioned in the App Store:

Support Contact »

Thank you Dijker.
I already sent an email to the developer. i just was wondering if someone has this device already in use.
You are right, the bulb could be a placeholder for all light devices.

EGLO answered
Like Dijker mentioned the bulb stands for all light devices from EGLO.

They told me that it might be necessary to update the firmware via the Awox app in order to use the panels with Homey.

In case someone else is interested in those devices.

1 Like

Quick question. Will the EGLO lightbulbs connect to the hue bridge (I am using the hue bridge in homey)? On every retail website, and review site it is said that the products (connect z) work with hue, but I can’t get it done, and I can’t find a how to.
I used the EGLO app for homey and that works great by the way. It’s only that I have but two bulbs from EGLO on different storeys, so I’m a bit worried of the quality of the MESH network. All my lights (quite some), switches and sensors are connected to the hue bridge.

Hello everyone!

As I’m new to this I have no clue what to do and I can’t find anything through a google search either.

I can’t get the Eglo remote 2.0 controller to work in Homey. I’ve installed the app and connected the unit as It should, so to this point everything is working.

I’ve set up a flow as follow:

WHEN: Brightness up pressed
THEN: Turn up the volume

It works when using another remote such as an Ikea Trådfri (of course with the proper card for trådfri). The flow also works if I run it through the app. So I’m confident that the last part of it is working properly. As it only contains of two parts it has to be something with the Eglo remote.
I’ve noticed there is two tags in the flow card, “Long press” and “Group”. Does it have something to do with this?

Please, point me in to the right direction as I’m totally lost here.

Best regards, Kent

1 Like

I have the same issue: the remote 2.0 is connected and flow items are available, but none of them work…

There is a known firmware issue with the remotes in combination with the 2023 Homey Pro due to changes in the Homey platform. If you want to be updated when it will work again, make sure to send us an email at homey-eglo@drenso.nl (we do not check this forum, it is pure coincidence I saw this).

1 Like

thanks, sent you an email

I connected a Eglo GRB pannel to Homey with the Eglo app.
I created a virtual knob to switch the panel to dimmed green light. Works fine :slight_smile:

Allso created a knob to set the panel to 100% white light. This light however is blueisch.

How kan i set it to real white with a flow?

Problem solved:

Hi, I installed the EGLO Zigbee RGB+TW (EGLO connect.z). Pairing to the iOS app works fine, but adding it in Homey does not work. I work with model: Homey Pro (Early 2019),version 10.0.6 After resetting the device, the iOS app can find the pairing session but Homey does not.


And it is a duplicate post,
therefore removed !