Developer Tools: Error message [object Object] when entering the Zigbee and Z-Wave page

Does anyone know what this means?


As mentioned in this thread, Athom reduced the timeout on the developer pages from 30 to 5 s. Could the error message [object Object] also have something to do with it?
Btw, I haven’t noticed any problems so far.

Check your browser’s developer console, perhaps there’s more info here. But random errors like this happen to me all the time on the developer site, on various pages.

Do you mean something like this:

Btw, I have absolutely no knowledge of the subject… :man_shrugging:t3:

Looks like you may need to log out and back in again.

It seems that was the solution. :joy:

Thank you very much! :+1:t3:

Hi @robertklep, after some days it appears again. @Peter_Kawa has the same problem. Any idea?

If it’s the exact same issue, log back in again :stuck_out_tongue:

But random [object Object] errors have popped up on the developer site for ages now, seemingly random.

For me, it just started a few weeks ago. But I use Homey since 2019… :thinking:

Check your browser’s developer console again, perhaps it’s a different issue this time.

For me it also started a few weeks ago. To me it seems v7.4.x related.
I got these messages too

For f.i. the zigbee overview, it then only shows device 0 Homey
Only after a manually refresh all my zigbee devices are listed again.

In the mobile app “Homey offline” notifications are very, very rare;
so Homey isn’t really offline, or does it suddenly respond not quick enough?


I’ve had exactly the same problem for a few weeks. I had my pihole in suspicion. But nothing is blocked there. Unfortunately, support doesn’t know what the problem is either. :frowning:

@bjoern are your issues solved when reloading the page?

@robertklep no… but:

I have seen in the browser developer tool that connections to are blocked. Or cannot be resolved. Now have a local DNS entry for and my local IP created and now it works. Something seems to be wrong in homey?

1 Like

A reasonably secure home internet router will not allow DNS requests that resolve to local IP-addresses ( resolves to, because that can be used for breaching private networks. These are called “DNS rebinding attacks”.

However, in their quest for security (local networks are evil), Athom decided at some point (I think with firmware v2 but can’t remember) that you should be able to connect to your local Homey using TLS/HTTPS. But for that to work, Homey requires to be accessed through a hostname, not an IP-address. Hence the hostname. This allows a TLS certificate to be issued for the * domain (every Homey will have to download this certificate from Athom’s servers every three months or so).

Paradoxically, for this to work, you need to disable DNS rebinding attack prevention in your modem. So you need to downgrade the security for your entire local network just to be able to communicate a bit more security with Homey on your local network.

Luckily, according to Athom, the website and the mobile app should fall back to plain HTTP when it finds it cannot resolve the hostname. However, this is susceptible to failure, and when it fails, you’ll get the message that Homey is offline.

The method you found, adding a local DNS entry, is the safest way of solving this issue (however, most home routers don’t have the option to create local DNS entries, so users either end up with downgraded local network security or with spurious “Homey offline” messages).

1 Like


“Now have a local DNS entry for and my local IP created and now it works.”

Could you please explain how you managed to do that…(with Pi-Hole?). I too have Pi-Hole running on my network.


And @robertklep, thanks for the additional information. You make me learn!

@Eternity Yeah, you can create a local entry in the hosts file on your computer or directly in PiHole under local entries… :slight_smile:

1 Like

I checked the developers console but don’t see a similar error you have (, but do see this error:

I had a problem loading the web page of Homey. So I disabled Pi-Hole for 30 seconds, and than it loaded without an issue.

I googled on “Pi-Hole & ingest.sentry” and found a discussion that suggest this domein should not be blocked.

What do you guys think?

ERR_BLOCKED_BY_CLIENT suggests that you’re using an ad blocker in your browser which is blocking the request. I get the same message (also using an ad blocker) and don’t have issues with the page not loading.

1 Like

It happens sometimes… So I guess more is happening. This error must have been there longer, and the Homey page loaded without issues. Only now I seem to have this issue occasionally.

The only add-blocker is Pi-Hole.