Deleted Google Home Assistant can not connect again


For some reason i’ve disconnected Homey from google. Now I would like to connect it again but that doesn’t work. After connecting my account in het Google HA app i get the message ‘Homey is connected’. Then it begins to fetch the Homey data (i guess) and after a while there’s a time-out which says ‘something went wrong, try again’.

Off course i’ve rebooted my device but still no succes. Does someone has
a resolution for this problem?



Did you check the info/connection in your Google-account?

Hoi Hielke, Misschien, maar weet niet goed waar en waarnaar ik zou moeten kijken in mijn google-account.

If you could please keep the conversation in English as much as possible, then more people will be able to participate and help you. If you would rather not or can’t communicate in English then please check out Non-English boards/categories:

Dansk (Danish)
Deutsch (German)
Español (Spanish)
Suomeksi (Finnish)
Français (French)
Italiano (Italian)
Nederlands (Dutch)
Norsk (Norwegian)
Polskie (Polish)
Svenska (Swedish)

Has Ggl Assist been enabled?

And, from what I know, you just have to keep adding, or re-authenticate Homey until it works.

Otherwise, create a new Google account and use that one in Ggl Home.
This seems to do the trick as well.

Okay, will do next time. My appologies.

Wondering: what happens if you talk with google and say sync devices (after Hey google ofcourse)

Tried that but also got an error. Maybe there’s a generic problem with my Google Account? I’ll try to create another ggl account and Connect with that tommorow

I suspect that that there is something from Homey or referencing to Homey is still connected to your account (only 2 things possible: rights or devices). But most likely it will be something not visible.

1 Like

Unfortunately, I am experiencing the same problem. My Google devices stopped being recognized, so I decided to remove the connection with Homey and re-establish it.

The video below shows exactly what happens. It seems that there is an issue occurring after the API link? Probably where the devices are being registered with Google.

To activate the integration (synchronization) with Google, a successful connection is first needed. Setting this up (as seen in the video) does not seem to be working.

What I have done:

  • Reinstalled Google Home
  • Removed the home (in the Google Home App) & added it back
  • Restarted all devices from the modem to individual Google minis

Any help to find out what is wrong would be greatly appreciated.

There are 2 (main) links between Homey and Google:
1 - to show all your devices which are connected with Homey in Google Home (so you can control all your devices with Google Home and also start flows from Homey). This connection is described in:

2 - to control your Google-devices within Homey; this you do with different apps but probably mainly with Google Chromecast.

@Genotix; the problem you describe

Unfortunately, I am experiencing the same problem. My Google devices stopped being recognized

is I presume that your Google devices where not recognized in Homey. Normal solution would be reset the app you are using (or if that does not work reset Homey or delete the device and add it again).

But that does not help your other problem (you show in the video); I have no solution for that. But things you can check:

  • In Google Home all devices connected to Homey should be gone. Are they?
  • In your Google account somewhere you can find the connection with third party services (for both 1 and 2); what do you see there?

Last resort: is you need to use a new account (as report it to Google will probably take a ling time before you will get an answer).

Hi Hielke,

First of all, thanks for your prompt response.

I’m sorry; my wordings have caused confusion thanks to GPT-4 translation. :man_facepalming:

My homey devices have been configured and -shared- with Google Home for several years (My previous homey was an early 2016 which also had this setup the moment this was possible)
The sharing Homey devices with has recently became “buggy”.
Several of my living room devices weren’t responding anymore so I wanted to fix this.

Having set this up about 6 or 7 times in the past, i know how it works; the integration from Google to Homey though doesn’t seem to work anymore and I have -zero- logging ability in my Google Home so I’m in the dark. (Literally :sweat_smile:)

I also have a Google Casting plugin installed; no issues with that.
Indeed a different type of “link”.

I have removed the link from my Google account to Homey.
This URL allowed me to change Third Party links.

After that I’ve started the link again and it was added on the same page as where I had removed it.
Unfortunately the same error occurred.
I think the API token exchange is ok but there is something “crashing” at the sync of the devices.

No other problems with the list of devices? like in Homey-app or web-app?

About a month ago I experienced the same problem. After a week trying to reconnect, reset Google Home and rebooting of Homey I gave up. I switched to Alexa now and have 2 obsolote Google Home devices in my house now :-(.

It seems to happen more and more to people with no solution, so I think you just have to give up and stop using Google Home with Homey :frowning:

1 Like

Just curious: you tried a complete factory reset of the or one of the devices and/or using a different Google-account?

1 Like

Nope, all good there :+1:t2:

Sounds like the Google integration is broken if you ask me.
Technically I’m pretty sure this is a simple thing to fix and it might be in the part where Google does a device “sync”, not in the token exchange part, given I am receiving a “Homey Linked” message and -after that- things go wild.

I’ve been setting up the Apple Home integration of @robertklep but the  integration itself is not as extensive as google and I still have 6 google devices that are bricked to the level of that I use them as a timer. :man_facepalming:t3:

I have created a separate google account and attempted to link to that.
Same effect… :man_shrugging:t3:

I didn’t factory reset Homey, just rebooted it to be sure. Factory resetting Homey just in order to get Google Home working was too much an effort for me. If it needs that (after working for more than a year) , I think I won’t use it anymore.

Another Google Account I also tried and got the same. Only the message “Account is linked” and after that “something went wrong”

As more people say, the integration with Google is broken and there is a need to dive into that for the Homey (combined with Google perhaps?) developers.
I’m already active within system administration (primarily Linux combined with cloud) and never got things broken until a point that it couldn’t be fixed. This one is, so I declare the software to be broken :slight_smile:

1 Like

Same here… nothing works