Again, connect to google home not working

I know this has been up so many times but there i still no solution!
I just want to link my homey to my Google Home system and Google Assistant. I have tried downloading Google Assistant from a US account, changing languages to English and so on. Tried combos, uninstalling, removing, resetting, different devices but it always fails. I even had it working for a short while like a year ago and then something changes and back to not working. I cant understand how this can be so complicated and also how Homey can say it supports Google home when it seems lik just a fuzz. The latest now is that on Google Assistant it understand that it should link however upon trying it just show an empty screen and pressing the dots it just shows a white page. You can see the screen shots

Does somebody has this working? Is there a real guide to get this working that you can follow or something like this?

2 posts were merged into an existing topic: Google Home discussion topic

Like u said in the topic title: Again.
There are several topics about this alr so this one is closed. If u have any problems with that plz feel free to contact @Bram