Changing Zigbee Channel?

In several older posts I read the zigbee channel can not be changed. It seems that in the 5.0 Beta FW this has changed (not sure if thi swas also in 4.2 because I am new to Homey and started with the 5.0 RC). I have about 35 devices linked, about half of which powered/router so plenty of coverage.

I also found the reference to this page:

On the Developers page - Tools - Zigbee there is a dropdown where you can change the channel. In my case it’s currently set to 16, which is in the middle of crowded wifi 2.4Ghz channels around our house. So I thought I’d change to channel 21, close to wifi channel 9-10, which seems relatively quiet. It displays a message that some sensors might not automatically reconnect, and when I choose to continus I unfortunately get a bunch of Network errors, and the channel stays at 16. :frowning:


  • How does Homey pick this channel?
  • I guess it stays fixed forever once it’s set?
  • Why does it only go up until Ch 21? Hardware limitation? There seem to be 26 channels defined in the Zigbee standard?
  • When I reset Homey and restore a previous backup will it also include the Zigbee channel (I assume it does, just asking)?
  • Has anyone ever succeeded in changing the channel without starting from scratch? :slight_smile:

BTW: Pressing the reset button on Aqara sensors once seems to work fine to reconnect, or start a re-pair if that does not work.

[Update] Opened a support ticket with Athom.
[Update] They found a possible issue and are investigating.

1 Like

Did you find your issue?
im facing simaler issue

  • Only if you RESET zigbee (and lose all paired devices) it scans for a quiet channel by itself and selects the best channel number. Otherwise only you can change the channel manually.
    And maybe it changes the channel after a factory reset. Many Homey’s seem to be on ch.11, sort of default channel (I assume)
  • You guessed right. Channel is permanent once after it’s selected, except when (factory)resets of zigbee or Homey itself are performed
  • Not all zigbee devices support channels 22 to 26 (I guess Athom didn’t want lots of questions and complaints)
  • No, when performing a factory reset, I assume zigbee channel is 11 again, but not sure. Restoring a backup does not influence the current zigbee channel (I’m almost sure, but it is an assumption)
  • You can change the channel, but you could lose some paired devices. Most of the time they’ll adapt to the new channel in a certain amount of time.
    *NOTE: This is different from a zigbee RESET - This will lose all connections forever, and all your zigbee devices have to be paired again after this.

I’m curious which posts that may be. I haven’t heard of this. (Homey owner since Oct 2020, started with v4)

Which version do you run now? I’m on the official v5.0.2 at this time

This is the page I recommend to Homey owners with zigbee issues

Changing channel has only become available from Homey v5 where the zigbee core was completely rewritten, before this it was always channel 11 and couldn’t be changed (also why most people are still on channel 11)

1 Like

Thanks! Didn’t hear about this until today.

Maybe you know this?

  • My zigbee channel was set to 16 after a zigbee reset; After a full factory reset, firmware v5.0.x, does the zigbee channel jump to 11 again? Or is it untouched?
  • And with a ‘new’ Homey, when you connect it with your wifi network for the 1st time, does zigbee look for a quiet channel after that? (which seems logical to me). Or do you have to do a zigbee reset yourself after you connected to your Wifi?

I’m not even sure the channel chosen after a zigbee reset is chosen based on quietness of that sub frequentie, or just because channel 16 is cleaner by default.
Most channels I see come by after a reset = channel 16.

Choosing a quite channel is something that will (should) take time, and nowadays with the newer WiFi routers that can auto change channels, if it is even possible.

A quick update for future reference: on HP23 an acceptable way to change the channel is to choose “Reset Zigbee” from the developer page, repeat until Homey selects the channel you want. All devices will still be present, but in failed state. You can then repair them one by one. That may take a while, but at least it doesn’t break any flows or insights.

I recently changed from CH11 (interference with neighboring APs on Wifi CH1) to CH15 and that solved a lot of zigbee stability issues (mainly missed motion and stopped reporting). It took me about an hour to re-pair 60 zigbee devices.

BTW: Restoring a backup does not work, the backup contains the Zigbee channel setting as well.

Update 2w later I am experiencing the same isues again (delays, devices not responding and even dropping from the network). unfortunately the wifi utilisation in the neighborhood seems to have changed, causing interference on Ch15 again. I am going to try to set Zigbee to CH25 and see if that solves it once and for all.

Add.: Might be obvious, but make sure the wifi channels are set to fixed before resetting the zigbee.
The zigbee reset process should find and use a quiet channel by itself.

Update 2: A few more weeks later… On CH25 things seem to be a bit more stable, but I occasionally still get delays, mainly during the early evening (so probably still due to interference).