Cannot continue restore by browser

Hi everybody,

My zigbee netwerk is broken and Athom suggested to put Homey in recovery mode and re-install the system. I go to on my laptop. After selecting language and hold ALT to select to use the brower i get to this screen telling me to connect to Homey’s Wifi. No problem so far but after connecting to Homey WiFi the button to proceed is grayed out and i cannot proceed. Maybe i am doing things wrong but i tried it 10 times already but i am just stuck at this screen. Anybody got a golden tip for me?

Would love to have my Zigbee network back up and running as i cannot control my lights now :rofl:

Thanks everybody!

Is your network 2.4/5 Ghz then you should temporarly shutdown the 5 Ghz.
Homey can’t use 5 Ghz

Hi Hugo,

Sorry for my late response but the problem has been resolved by using a MacBook to reset it.

Best regards,

That’s ok.
As long as your problem os solved.


Sorry to hijack the thread, but I’ve got the exact same problem as Martin, but no access to a MacBook. I’ve tried doing the setup on a W10 laptop (chrome and edge browsers) and on a android tablet (chrome browser) but no luck so far.

Can you guys think of an alternative solution? Of do I have to prepare installing an hackintosh pc?

Send a support request to

Support ticket was the first thing I did of course, but since it’s Saturday I’m not expecting a solution to the problem any time soon.

Installing Mac OS (or using a Linux boot drive for example) would be a faster solution for my problem, but a lot of work. That’s why I’m hoping that someone else had a quick and easy fix for such a stupid problem

I have exactly the same problem and I have tried the same devices, win10/chrome and android smartphone. I have disabled the 5GHz network, makes no difference. I swapped my two Homey’s between my flat and my summerhouse. Both are v7.1.4. The newer hade no problems recover to my summerhouse wifi but the other one, the older, won’t work in my flat. What can I do?

Support advised me to try firefox browser (on my W10 laptop) and that worked flawless for me.


I tried with my Samsung Galaxy Pad and it worked fine. Seems that there is some differense between the devices. Can it be firewall, network, virus program that makes difference?? Since I have no debug program or instruments I can only guess but now I am happy and my Homey’s are functional again.

Thank you for this tip! I was trying to reset my homey for 2 days because I experienced the exact same problems (zigbee dead and no chrome and edge didn’t work). Downloading Firefox worked for me.