BSH HomeConnect login not working

Trying to add a Bosch dishwasher. App is asking for HomeConnect credentials. After entering the login details and granting some permissions, Homey tells me: “You I can now close this window”. After closing it, an almost empty page comes up saying “Please log in to the website of the manufacturer” (Bitte logge dich auf der Webseite des Herstellers ein) . A wheel is spinning above this sentence. FOREVER.
Killing the Browser window even after 30 minutes terminates the process of adding the device.
Credentials are correct, but the login doesn’t seem to work.
Same with the testing version of Bosch-Siemens Home Connect app.
Any idea?

Just tested with v2.3.5 and my Bosch wasmachine and it worked as expected.

Did you add your device in the home connect app first?

So yes, delete the homey BSH app, restart app, reinstall app, login in the home-connect app and try adding the device with the BSH app.

So no, add device in the home-connect app, and try to add the device with the BSH app

1 Like

Yes, the dishwasher has been running in the Home Connect App (Android) for weeks without problems. I just did the following:

  1. uninstalled Bosch-Siemens HomeConnect (Homey)
  2. opened Home Connect (Android)
  3. waited for the dishwasher to come online
  4. reinstalled Bosch-Siemens HomeConnect (Homey)
  5. tried to add Dishwasher as Homey device.

Same as before. But I saw a new error message by pressing the back button on my Android device (before I hit X in the browser to close the window):

{“success”: false, “message”: “invalid_id”)

I’m not sure what ID is meant here. But I guess my username:password for HomeConnect get rejected. I don’t know how HomeConnect servers are constructed. Could it be a localization problem? I’m living in Norway, but my Homey is set to German language. Is it possible that Homey calls the wrong login site (i.e. German instead of Norwegian)? The Homey app seems to redirect me to a site called “” for the authentication process. I tried to access this site via browser, to see whether it lets me log in via browser. But the address does not allow HTTP access.

Don’t know about localization, can’t imagine that the language of Homey Matters. You have a European Homey and not a American or Australian Homey with other zwave/zigbee implementations.

Problem is oauth. Are you sure your login is correct? Logout from home-connect, fill in your username, copy paste this in Homey when adding your dishwasher, same with your password. Just to be sure

Just did it. Installed Home Connect on an old tablet and logged in. No problems. Opened Homey on this tablet, added dishwasher device through BSH, login with same user name and password: error.
I noticed that both apps direct the user to the same login site: The address continues with a long string of values like client_id etc. These additional information is different for the HomeConnect app and the Homey app. I guess this is normal and doesn’t mean more than that the login methods of both apps are different. But somewhere here the problem seems to have its root.

Solved the problem. Just had the idea to do the pairing process in the Homey developer interface. Worked without problems.
The developer of the Bosch-Siemens HomeConnect app should have a look at this. Apparently the browser login command is called in a wrong way on Android, at least for some configurations. Since I tried with several mobile devices (Samsung S7, Samsung A5, Huawei), the mobile is not the cause. It must be the way my Homey is configured (not that I did anything special with it, but I have similar recurring problems with the Alexa app that only few people seem to experience).
If the app developer wants to have a look into this, please turn to me. I’ll do what I can to help.
Thank you everybody,


Thanks @Sven_B for helping me to find a way to login.

Thank you, it worked finally via the developer interface. You reported this back in 2021 :anguished:

Thanks, I had the same issue with my Siemens appliances finaly could add all 8 devices. So the issue still remains now it’s 2024…