[BOUNTY] - €40 - Convert existing Pioneer app to Homey 2.0

I can add my device but I can’t control it. It says that its not connected with the device

From the log is see it is trying to connect using port 3911 instead of 8102 thats is probably why the connection is refused and you are not able to controle the device. Question is why it reads 3911 as port while the screenshots you send me earlier states 8102 like mine does…
Could you please check again

In max a couple of days I will release an update where you can mannually re-enter the port.

Checked it, port 8102 is correct

Hi, guys! Great idea to revive the app. Just installed it. Homey 4.0, iOS Homey app.
Found my SC-2024 automatically, can turn on/off.
The inputs list only shows DVD, my receiver was set to TV, the Input menu does not work.
The volume changes from -25 to -55 or something.
Just tried using it again from the devices page, can still turn on and off, but when I long-press to get to device controls, the entire Homey app now goes white blank, have to restart the app to control anything.
PS Count me in for EUR20!

Firefox reports this from (Chrome/Safari give errors)

1 0 1 8102 DMR-1.50 MS_DigitalMediaDeviceClass_DMR_V001 MediaDevices VEN_0112&DEV_0004&REV_01 VEN_0033&DEV_000C&REV_01 Multimedia.DMR urn:schemas-upnp-org:device:MediaRenderer:1 Pioneer SC-2024 (Master Bedroom) PIONEER CORPORATION http://www.pioneerelectronics.com Digital Media Client SC-2024/SYXJ8 Digital Media Client uuid:5F9EC1B3-ED59-79BB-4530-745e1c57f22d 123810928305 urn:schemas-upnp-org:service:RenderingControl:1 urn:upnp-org:serviceId:RenderingControl /RenderingControl/desc.xml /RenderingControl/ctrl /RenderingControl/evt urn:schemas-upnp-org:service:ConnectionManager:1 urn:upnp-org:serviceId:ConnectionManager /ConnectionManager/desc.xml /ConnectionManager/ctrl /ConnectionManager/evt urn:schemas-upnp-org:service:AVTransport:1 urn:upnp-org:serviceId:AVTransport /AVTransport/desc.xml /AVTransport/ctrl /AVTransport/evt

@Ruskie many thanks for trying the app. Not sure why the app went white.

Do you mean your maximum is -25 and minimum -55 when using the volume level slider? If, yes can you tell me what your minimum and maximum levels are when using the remote?

It is correct that the input source only is showing DVD. That was a test for the development but was not meant to publish. Because there is no code behind it yet.

Two more notes:

  • can you run the description command again from another browser like IE or Firefox otherwise it Will give the error instead of the real page.
  • can you also try: http://your_ip/StatusHandler.asp
  • Please see post just above - our posts crossed :slight_smile:
    {“Z”:[{“MZ”:{“P”:0,“V”: 37,“M”:0,“F”: 5}},{“Z2”:{“P”:1,“V”: 61,“M”:0,“F”: 1}},{“Z3”:{“P”:0,“V”: 21,“M”:0,“F”: 1}},{“HZ”:{“P”:0,“V”: -1,“M”:0,“F”: 6}}],“DSP”:1,“L”:“0501”,“A”:-1,“HOA”:1,“LC”:“MUT” ,“MA”:0,“MS”:“0000000”,“MC”:0,“HP”:0,“HM”:0 ,“DLBES”:1,“DLBSR”:1,“MN”:“SC-2024/SYXJ8”}

Hmm… restarted iPhone - same problem, - one big white screen, other devices work fine showing controls etc

As for volume - can change between +12dB to -80dB using the IR remote


I have the same problem with long pressing. The last thing I did was move the input slider to DVD… No idea if that has something to do with it.

@Ruskie was the output on the browser looking like this.

Because i think it is reformatted by the forum like Dennis wrote.

@dENNtoet i Will try to reproduce this.

Yes, I copypasted the output and it ate up all LF/CRs :frowning: Will do a screenshot once I am home if needed

Bonjour et merci pour cette nouvelle appli. Pioneer.
Je l’ai testée, mais mon VSX 529 n’est pas trouvé sur mon réseau…

Hi, and thanks for this new Pioneer app.
I tried it, but my VSX 529 is not found…

See a new test version: https://homey.app/a/com.pioneer.avr/test/

this version should be a solution to the connection with a wrong port. Otherwise you can change the port and ip using the settings. However, manually changing the ip is not recommended as it is in contradiction with the build in Homey device detection. Changing the port does not have that issue. It could be that you have to reopen the device after changing the settings manually because it does not yet work flawless.

Would be great if you can post the screenshot. It helps to gather as much data as possible. To make the app more generic.


Strange that your device is not found. Could you also try http://your_device_ip:8080/description.xml using Internet Explorer or Firefox and share a screenshot?

Nothing changed for me after uninstalling the old version and installing the test version.

I can add the receiver… But when I want to do anything it says: not connected to the device.

I changed port numbers to 3911 and the default one.

What do you see in the device settings after adding the device? There should be the correct IP and port. Are u using any other application with the pioneer at the same time?

Can you send the logs from this?

Send the logs.

So strange thing is that when the device is on i can control it.

But I can’t turn it on via the app. Network standby is on.