[App][Pro] Onkyo Receiver

Onkyo/Pioneer receiver app

Control your Onkyo network-enabled receiver
Some Pioneer receivers will also work.


Gerenal settings for
* IPaddress
* Port (typical ports used are 60128, 8102 or 23)
* Maximum volume settings (Maximum volume that will be send to receiver and slider scaling)
* Volumestep (for the + and - on the devicecard(s))
* Receiver volumestep (some receivers do 0,5 volume steps instead of normal 1 steps)

Sererate devicecards for main zone, zone2 and zone3 (main zone is mandatory)

Capabilities on devicecards:

  • On/off
  • Mute on/off
  • Volumeslider (scaling with the Maximum volume setting)
  • Volumeup (with volumestep setting)
  • Volumedown (with volumestep setting)
  • Input


  • power on
  • power off
  • volume change
  • Receive custom command (general flow)


  • Turned on / off


  • Turn on
  • Turn off
  • Toggle on/off
  • Set volume to.Paypal Donatation
  • Mute the volume
  • Unmute te volume
  • Turn the volume down
  • Turn the volume up
  • Send custom command (general flow)
  • Send RAW EISCP command (general flow)

After install go to the general settings and set the ipPaddress, port, maxvolume, volumestep and receiver volumestep.

Add the device(s), main zone is mandatory.

App using the node-eiscp from GitHub - tillbaks/node-eiscp: node module to interface with onkyo receivers (eiscp protocol).

The syntax is: zone.command=argument.

  • Example : main.power=on
  • Example : zone2.volume=22

Also possible to send RAW EISCP command like PWR00 for power OFF or PWR01 for power ON
Check the command list

Supported Languages:

  • :uk: English

If you appreciate this app, contribute to future development by making a paypal contribution


Apps made by @mickelluiten


Will try tomorrow!

As mentioned in Slack channel, i’m getting a message

No response from receiver, check IP message when trying to add the device.

It is turned on, and with the old app installed i can add it without problems.

Hi Martijn,

Did you fill in the correct Ipaddress is in the general settigs.
…More, Settings , Apps , Onkyo Receiver.
There is no more autodiscovery anymore

IF it still not working, please send me a DiagnosticReport.

Yes but that’s not possible because I cannot add a device.

If I have the device installed on the OLD app, and update the app i cannot change IP, so I have to remove the device.

If I add it, it gives me this error as stated above. No device will be added.

That is correct , therefor the remark :
WARNING : Because of the new coding the old app completely breaks down all devices and flows.
Advice is to remove all devices and deinstall the app. before installing the new one.

I don’t get you. I know there is a warning, I have read it and I totally get it.

But you suggested to change the settings manually, for that I need a device, as i cannot install a new device and cannot get past the adding of the device… … so I figured maybe you meant adjusting the original device and the only thing that breaks is the settings… but clearly I was wrong.

I created a small movie to show you what exactly happens:

Thanks for the movie, will check it later this day, for now its not playing on my phone

In the old app the ipsettings where discoverd by a broadcast and saved in the devicecard.
The new app there is no discovery broadcast anymore and the ipsetings is saved general(managersetting), because of the mutliple devicecards.

If you did not deinstall en remove the devices from the old app, the new app shall not work.
Before you getting the devicelist there will be a short check if the app can create the socketconnection to the receiver.

The message “No response from receiver, check IP message when trying to add the device.” tells me that there are no ipsettings or wrong ipsettings in the gerenralsettings.

So maybe you can deinstall ever thing install the new version set the ipadres and try it again,
if still warning go to …more , apps, onkty receiver, open settings (right corner) and create a diagnostic report, and the IPaddress from your receiver i need to know

Sound logical, but I have deleted the App and device and still the same error. I’ll try and reboot in between.

Thats strange , tryed it many times with no problem

Can’t play the movie,. Can you make a screenshot from the settingpage and generatie the diagnosticlog?

Here works everything fine. The settings „IP- Address“ must be done in the App itself. Not during add a device.

1 Like

Yes, that was it. After install you mean after app install, sorry I misunderstood. Now works

Great,. I was almost worried that something was wrong in the code

1 Like

I’ve been testing it a bit, but do you remember back in the days there was an issue when turning on the receiver with Spotify Connect? That problem is back (makes sense if it’s a complete rewrite).

So, receiver is in standby. I open spotify on my PC and choose the receiver. It wakes from standby and starts playing. The app doesn’t notice the receiver has been turned on.

Yes , i do remenber that…wasn’t sure of the rewrite going to fix this weird issue.
Will taken a look at the old code en write this part in the new code this week.

Hi Mickel,

Installing the app just went fine. However, configuring the IP adress seems to hamper.
The config seems to return to default settings after some time. IP adress returns to
Removing the app, installing it again doesn’t seem to make any difference - tried several times.

Any tips on how to proceed? (using Homey 4.2.0)


I install it too, everything looks fine. But i get an error! This is the diagnostic report: 782e3e24-d18e-4682-927f-b6a5edecb9ee


Hi Rene, i have seen this setting a few times, trick is to always hit the save button.
But working on a fix for this.

HI Arie, have received you tracelog the fault has to do with the pairing, before addding the devices there is a short check if the receiver is reachable.

Are you sure you set the correct IP address for your receiver? accoridng to the received tracelog its IP : , and if this a fixed ip address?
This because during pairing you don’t getting a error like Martijn did in previous post , so an IP is filledi in, but there’s no connection to receiver and afcourse no data ,
Look like that causing this error.

Be sure you follow the steps in the readme or frst post
deinstall the old app(v2.3.1 or lower),

  • install the new one, V3.0.0 or higher)
  • before pairing go to the general setting and set IP, Maxvolume and Volumestep.
  • torn on your receiver :slight_smile:
  • go to pairing and add the Mainzone and optional zone2 or 3.

If sitll not workinh please sens me some screenshots from settings , paring etc and the exact steps you do to add the device in a PM, i then can see if i can reproduce it , or/and built some extra debugging in the code.

@Martijn_Hoogenbosch, @Rene_Esvelt , @Arie_Ruitenberg and all others

New verion 3.1.0 is online in appstore(test) see link in first post.

Should solve all problems :slight_smile:

  • Inprovement in the pairing process.
  • Inprovement for the general settings.
  • Better handking in case of lost connection to receiver.
  • "workarround"for spotifyconnect because of receiver bug.

Can you all please test again and give me some feedback.

1 Like