Automatic blinds / Somfy?

I’ve got a new house. It has 4 sunscreens which are controlled by a remote. See picture:

There is absolutely nothing in the remote except for a label on the inside with the battery saying 5107752A00. I cannot find anything for this.

As shown on the picture it has four little status lights, with the button i can swap lights which represent the screens and a mode where they all light up thus controlling them all together. On the bottom it has a small black button which resets something i guess.

Ive added somfy RTS to the homey and it adds screens if I follow the procedure but it doesn’t control the screens afterwards.

Then I don’t know for sure if it is a somfy motor or somfy IO or RTS. Or a cheap ripoff… I cannot find a central control unit in the house anywhere. All outlets are well hidden, haven’t found them.

Basically I want to know how these kind of devices work, so should there be a central box or anything, and what’s the next best step to find out what they are? Which brand or if it is supported by Homey.

If you can add it as Somfy it certainly will be Somfy. I also added my sunscreen(Io) from somfy and it also does not work with Homey, although the device has been added.

I also have a Tahoma Box(probably connexoon will also work), that way you can handle the devices with Homey. In my Tahoma Box i can add some scenarios, these scenarios you can access through Homey flows.

Also the somy led lights under my sunscreen(rts) work with the Tahoma Box and Homey.

So to be clear. If there is NO RTS protocol in house, the Somfy app won’t add screens? Because pushing the button for 2 secs does make the screen go up and down briefly but hitting the program button doesn’t seem to do anything.

Try the Brel App, this worked for me on “chinese” motors

No you can add RTS screens with Homey. If it is a rts screen you will be able to control it(use Homey RTS app). It is also possible you have a IO screen, you strangely can add this io screen with the Somfy RTS app, but it will not function. In case you have an io screen you need the Tahoma Box to control it. With the Tahoma Box you also have the possibility to use the Somfy Tahoma app. With that app you can control your io screen with Homey.

I have added RTS led lights. In my case i had to try it different times before it worked properly. So pairing, adding, trying, No? And again deleting, pairing, adding, No? Delete device, delete app, restart, install app, pairing, trying… etc etc. After 5 times it worked for me.

And is there a way to know for sure its a RTS motor except for tearing it apart? Because I thought it was mentioned on the remote, but there is nothing on my remote which makes me uncertain it is acutally RTS.

Thanks, will try tonight

In my case I got this AB, on the backside it says IO

As far as I know io is a somewhat newer protocol. Rts is a older protocol, looking at your AB is looks a little bit older. Maybe you can ask Somfy customer service if they know what you have.

Okay, i’ve managed to get the supplier of the blinds and they could figure out what kind of system it is based on the remote control unit.

It’s the following:

  • fequency 433,32 Mhz
  • Asa ETR & ETR-A devices

So it is safe to say i’m fced, right? There is no app for this in the store.

How hard is it to for example get a version of one of the apps above and change this to this brand? Is it just changing hardware ID’s and some pictures, or do you actually have to work with spectrum analyzers to analyse the frequencies which are send to the device?

There is a Tool in Homey Developer that maybe can help you:

I thought that was just for internal facing emulation. So record en play as incoming signal, it doesn’t push out the commands.

Have you tried the ‘Brel’ app as suggested above?

Yup, doesn’t do anything unfortunately. Has a complete other way of paring, or seems to be like that.

Need to press up and down button to pair. But don’t know how to pair these, so did exactly what it suggests, but doesn’t do anything. Neither does pressing the button on the bottom side.

If you have any thoughts, please do share

Different question; Would it be possible to add a ‘dimmer2’ from Fibaro or even a smart implant to the rollers? This way i could circumstance the remote and just to it by Z-wave, right? I haven’t opened the rollers yet, first wanted to check if it is a possibility.

Hey Martijn, ik heb dit opgelost door de originele receiver eruit te slopen (ook een of ander vaag merk). Vervolgens goed in kaart brengen waar elke kleur draad heen loopt en hoeveel het er zijn. Dat uittekenen, zodat je weet wat je straks moet aansluiten. Tot slot heb ik er een ASUN650 (KAKU tbv zonwering) tussengezet. Zeer waarschijnlijk is dit inmiddels ook mogelijk met een Z-wave module.

Hey Martijn, I solved this by removing the original receiver (a non-supported brand). Next step was to map the original wiring (how many wires, what colour goes where, what’s the function). Then at last I used an ASUN650 (KAKU for sunscreens) to have the same functionallity, but with Homey-support.
I guess there’s also a Zwave module for this task.

The thing is, the sunblinds here have no wall-socket. So there is no place I can put in the ASUN650, I have not tried opening the outside unit, because that seems to be a bit hard being it build in the wall pretty tightly.

I think I’ll have to push the button … …

Ok, that makes it a bit more difficult, but I still think it can be done. In the end you’re only exchanging the current internal
device for the ASUN, which gives you domotica-options. The current device should be replacable, because after all, it will not have eternal life. Also for maintenance it should be possible to acces the electronics. If you want, I can have a look at it. Just to see if it is possible. If it works here, it should also be doable at your situation. If you want you can also have a look at how I did it here. Maybe it gives some ideas!

Make sure to pair any 433MHz device using a crispy new power supply on your Homey.
Been there, done that… and it worked for me.

Yes, I know, but it has this. Unfortunately none of the apps work.

@Koert_Walraven I have removed the ‘kapjes’ (?) but all electrical stuff had been built into the wall. I cannot get to it. So either have to completely replace the blinds (€€€) or find a way to emulate the 433mhz signals, which is no option currently in Homey… Again, i’m forced to use a button…

Or maybe some day, the “Microbot” will be an option (isn’t available in Europe for now)