Control Auto setting of Somfy systems


I threw out my (not so) old Telldus solution for the ability to control my Somfy blinds which works…apart from the fact that I cannot access the Sun/wind sensor nor control the Auto state.

Has anyone been able to control their Somfy systems with a sun sensor?
Especially controlling the auto state.


Are you using the Somfy Sun sensor?

I use the Tahoma bridge and the Homey Tahoma app which gets the light data from the Sunis iO sensor to control all my curtains and blinds.

If you are using the Homey Somfy RTS app then you will need a non-RTS / iO sensor as Homey can only send RTS commands, so can’t read those sensors. In which case you could use a light sensor connected via z-wave / Zigbee or WiFi.
All these solutions would require one or more flows to do the automation.

Edit: I’ve not come across the Auto state so can’t help at all there.


I don’t get any reading from my Somfy io light sensor.
How did you manage to get a reading?
In the Tahoma app it does work but there I don’t need it…

Strange, I have Sunsensor io in Tahoma and it loaded it without issue. Somfy app reads the values without issue. Try restart app in the settings or delete and add sensor again.

That i already tried but still nothing.
In my tahoma box i have complete readings but Homey does add but can’t read the amount of lux.

It works OK for me. I’m using homey version 2 in English so not sure if any of that is different for you?

Have u tried to reconnect it to Tahoma not only Homey?

I tried, yes.
Reinstall on Homey.
Reinstall app and after reinstall device on Homey.
Reinstall on Homey after deinstallation on Tahoma box.
And reinstall on Homey after reinstall on Tahoma box.
After every reinstall a restart of Homey, but no success.
On the Tahoma box it works, not on my Homey.

I’ve the sake problem. No luminance data in Homey app but appears correctly in the Somfy connexoon app…

Same problem here no reading from Sunis IO sensor.

I did.

1 Like

Hi guys, anybody knows why Somfy Tahoma receives multiple commands at the same time? In the end it works but these periodical flows get this error.tahoma tahoma

If you send the same command twice (or more) while the command hasn’t yet finished you’ll get the “The action on the device has been cancelled” message.
I sometimes see something like this in my Tahoma app but usually it does just work. What I mostly do however is let Homey set a certain Tahoma Scenario and in this scenario I select all the devices that need to do something (ie. a scenario to close the roller shutter in the living room which closes all roller shutters at once).

Hi, this is exactly how i created the flows on Homey. Scenarios in Tahoma app are triggered there. However I still don’t know why my flow triggers it three times in a row in Tahoma. In the end it works, but why that redundant traffic?

I’ve got the exact same issue with the Somfy Sunis IO. They are already part of my sunscreen setup and now I bought the Homey I want to controle the setup with flows. I have two Sunis IO sensors and the sensors can be installed without a problem, but the sensors don’t show any lux readings in Homey with the Somfy app installed. In the Somfy app on iOS, connected to the Somfy Connexoon IO bridge the sensor’s show lux readings and battery health.

Is there a solution for this issue? What versions of Homey (mine is Homey Pro v3.2.0) and the Somfy app on Homey (mine is v1.5.4) do you use when it works in your setup ?

I have a Sunis IO too and it does’t show readings in the homey app.
I did tell Athom But no reply.
In the Tahoma box it works great incl. readings, but I only use the Tahoma box as a gateway, because otherwise my blinds don’t work with Homey.
It didn’t work in any 2.x or 3.x version of Homey.
I did never have an older version.
So, with me it never worked.

I have the SunisIO and it works perfectly with Homey (Somfy Tahoma app 1.5.4). I have been using it for about 2 years to control when my lights come on and curtains close, etc.

The app is not written by Athom so you need to report any problems to the dev, Lennart Kuijs, via GitHub Issues · totalimmersion/com.somfy.tahoma · GitHub

P.S. It looks like the problem has been reported and occurs when certain other IO screens are also on the system.