Aqara FP2, mmWave presence detection on WiFi

Second new firmware 1.1.7_0002.0028

  1. Fixes some issues.

I don’t know what the issues are?

Those are some issues. :rofl:

1 Like

it broke my zone detection to homekit/ha. app shows it correctly but in HA only general presence seems to work.

I have applied all the updates but still not working very well. Sometimes when I move it will create an extra person with one staying where I was and the other tracking me. Then the stationary one never gets removed unless I reset the occupancy (and I have left it for over 30 minutes on occasions). I have spent ages playing with various sensitivity levels and zones, etc but still useless. I think it’s partly due to our floating floors which makes furniture tremble slightly as we move around and maybe it thinks that is another person. But if that’s the case, then why doesn’t it remove the person when the trembling stops.

So, I think I will go back to my cheap one I got from Ali as that works well apart from detecting when someone goes into the cloakroom next to the office. So, its not perfect but at least I don’t have to keep manually resetting it after I leave the room and it responds much faster to someone coming in and going out of the room.

I will keep updating the FP2 and testing to see if they can resolve the issues, but until then I won’t be spending any time on integrating it with Homey.

The cheap ones from Ali. Is that the tuya zigbee zy-m100? I’ve got those and there working brilliant.

Indeed much better than the fp2 although they don’t support multiple zones or interference areas.

I have them setup through a tuya hub and servers. Though I’d love to have them implemented directly to homey as they are ZigBee (there is a HA support for them)

Mine is a WiFi version but still Tuya. It integrates via the Tuya cloud app from Jurgen Heine.

Hello Adrian.

There where a couple things that improved the detection of my 2 FP2’s. My room is small and i approach the sensor from the side. That gave some problems that seems to be fixed.
First i set the “Present monitoring sensitivity” to low and i did this as well for all my selfmade zones. Then i set my “Distance of close induction” to close. Also my sensor is compared to the wall on the other side a little from the walls angle with 5 degrees. Maybe this had to do the bounching off the wave-signal to the wall on the other side.

The other problem is because i enter and leave the room from the side of the sensor it kept saying i didn’t leave the room, because it couldn’t detect me anymore, so i made that a “enter and leave”-zone. I also resetted the sensor will i was still in the room. It seems it is now working like i hoped it should.

Also placing the edge in the zone managment is important. And fill the empty space complete as edge.

Maybe this will help you as well?

1 Like

Do you use the FP2s with an original Aqara hub?

No. I don’t have to. It is WIFI based. It was the FP1 that you needed to connect to the aqara hub, because it worked with zigbee.

Just connect the FP2 to your wifi network and you can see it on your app. It works with local and cloud api.

Ah, very good. Thank you!
I‘ll give it a try. I. bought 2 of ithem to integrate them to my Homey pro.

edit: …in a positive future :grimacing::grinning:

But that’s not a Homey app while there isn’t one yet?

On this moment it is not possible to integrate it to homey. There is no app for it. And there is no one that is gone make a app. Adrian had the intention to make one, but had issues with the FP2 and has, on this moment, not the intention to make one untill the issues are resolved by firmware.

That is right @Peter_Kawa .

But maybe i understood him wrong, but his question was if he must use the FP2 with a aqara hub. It is not necessary. But on this moment with homey it is no go. :pleading_face::pleading_face:

Maybe ifttt. I could make one with routines in the google home app. If it wasn’t so slow.

Yeah, I wondered, why Rudiger seems to have the idea there’s a Homey app :blush:

When Adrian gets the thing to do what it should do, maybe there will be a Homey app , one day :wink:


Unfortunately ifttt stopped working for me a few days ago. Ifttt cards with the Aqara fp2 as trigger no longer run. Even whilst trying to run it manually it has no luck

How did you setup this? how to make this HTTP Request? maybe you can make a video or post some pictures? :slight_smile:

1 Like

If you’re not familiar with Tasker yet. I would suggest you check that app (for your smartphone) out first. It’s a very advanced app which (might) take some time getting used to it.

So if you want a fast workaround this isn’t the way to go. I also did not put that much work in it yet, because I’m first trying to get the FP2 sensor reliable. Lot of ghosts detected at the moment.

When you want to do it this way. You can search on the forum for a tutorial. There are a few good ones that explain how to link Tasker and Homey.

[TUTORIAL] Custom Android widgets/dashboard using API Builder app, Tasker & KWGT

[TUTORIAL] Using Tasker / KLWP together with Homey

also had issues on zone detection after an update , did some change on a zone and it worked again. maybe you have the same.

Hi Adrian

I will put £30 in the pot for a working version.

I will also give 30€.

1 Like