[APP] Somfy Tahoma

I tested 1.6.23 and it’s indeed fixed. Nice feature to open/close window covers / sunshades quickly :+1:

1 Like

Sorry been away for a while. I tried to install Somfy TaHoma & Connexoon v1.6.23 SDK2 but it fails with an error. Does is require v5+ firmware?

It should work on older Homey firmware.
Do you have the problem to install it or use it?

Sorry, I was not very clear. I tried to install it, but it failed with an error (version something). I now see it is installed. Thanks!

I have just had a chat with Max (community store author) and it seems the app might be getting too big so it’s timing out during the download. V5 uses a different instalation method which doesn’t have timeouts.

I think I need to optimise it a bit and replace the old http library with something a bit more modern and smaller.

Until then it could just be a case of keep trying.

1 Like

That’s a nice explanation, I got errors as well, but the actual installation never failed. In other words, when I got the error, I also saw at the same time the LED ring installation lights of homey. :smile:

So does it actually install on v4?

As I’m on v5 and have no issues I can only go by what I’m being told and that was it’s timing out during the download / installation.
Max installed the app on his v4 Homey via the CLI and it worked fine.

Yes it does, I’m on v4.

But as I said during the installation I receive an error, but even with this error it installs fine. In my case it did not fail.
This is the error I saw when I installed 1.6.24:

It says:
Cause of an error the app couldn’t be installed. TypeError
But in my case it did install on a Homey Pro with 4.2.0:

1 Like

Thanks for the update.
It’s a strange problem.
Do you know the which was the last version that installed without this problem?

Maybe I can view the changes since then to see if something stands out.

I don’t know. I was a long time on the official one. I do know that on 27 August I saw the error while installing 1.6.9. But I have no clue, when it was alright.

1 Like

Ah, OK so it has been a problem for longer than I realised.
Thanks for the information.

I have published a new version in the Community Store. It is much smaller now after converting to axios for the networking. That alone nearly halved the size of the app plus it is much more efficient so it should also reduce the CPU load.
I’m not sure it will fix the installation issues for Homey V4 users but that problem has been worked on and an update to the Community Store will be coming soon.

1 Like

Installed on v4.x without receiving an error! :+1:

1 Like

1.6.25 works great. I do see the error message, but like I said before, it’s a false error, cause it does install perfectly.

This is what I see:

2. (takes some seconds)

3. Then picture 1 appears together with this:

But again when I go to homey app, 1.6.25 is installed :smile:

I’m on homey 4.2.0
Homey app
Android 10 with Chrome browser

The Tahoma app has now been officially handed over to me so I have published the first test version in the Athom store https://homey.app/a/com.somfy.tahoma/test/
Although that version is 2.0.0. it is the same as version 1.6.25 in the community store. I just had to make a few changes to change log file and the readme for the Athom store. I will eventually synchronise the version numbers once Athom Store version becomes stable.


Thats great to hear Adrian. Your job is amazing! Thanks
And I love the one tap open/close which I asked. Next level is live icon on the tile but the tiles are pain in general.

19 posts were merged into an existing topic: Somfy Tahoma & Connexoon (v2.0.2 | Test: v2.0.3)

Can we somehow switch from this forum to the new one: Somfy Tahoma & Connexoon (v2.0.2 | Test: v2.0.3)

Makes more sense now @Adrian_Rockall is the owner of the app.

Like close this one or move messages to the other side :smile:

1 Like

Agreed, i will do even both, have moved all relative posts for the new app to the new topic (where they belong) and will close this topic, any further discussion can continue in the official new topic.

If you have any issues with a post being moved or me closing this topic, feel free to contact me or any other moderator.