[APP][PRO] YouLess, Enelogic, PVOutput - Belgian and Dutch P1 Smart Meter Reader

You can use Power By The Hour for that. [APP][Pro] Power by the Hour: Insights per hour, day, month and year
But you need to use a virtual device in PBTH and feed only the return kWh to it via a flow (e.g. on every change in return kWh)

I am using Power by the Hour great app but can you explain in a little more detail how to do that.

1 Like

See this example flow I am using myself:

So you first need to create a variable ‘Returned Energy’ and a virtual PBTH device. Then use the above flow. Note the 5 second delay in the final card!

And this is what I got (no energy delivered to the grid on this dark winter day :smirk:)

Thank you. Great that you can see your returned energy so precisely.

1 Like

Since the update from PBTH I get this message in the Youless and Enelogic app.

I have the same, nu thought it was because of this week’s installed heat pump

Unrelated to PBTH. You have a network issue. Try rebooting the youless

Problem solved by connecting the YouLess to another ip address.
Thanks. Have a nice day.

1 Like

Problem solved by putting back the p1 cable, constructers forgot that and I responded without checking on previous experience

1 Like

Hallo @Gruijter.
Since the last update the app wont give me the wattage/current per fase and broke some of my flows.

Homey @ Last firmware
Homey Youless App @ Last firmware
Youless Harware @ 1.5.3-EL (alsow last fw)
Meter funtionality: Repport 3 fases = Yes

What can i do to solve this? If you need more info let me know.

Fiddled about one hour, then got on this form to ask the programmer as you can see. After that within 5min found a solution.

First i, switch 3 fase off, save, turn it on in de Youless App on the Homey.
Then the Youless App kept on crashing, so i restart the homey and everything worked again including all flows.


Since my update to version 1.6.0 EL I don’t receive data anymore per phase:

This seems similar to the post from @JosB above. Is this something that happens more often and can be fixed?

@Jelmer_Knuivers @JosB

I only have 1 phase myself, so I need access to a youless with 3-phase info to reproduce your issues. If either of you is willing/able to provide remote access for me, I could check what is going on.

I would need your external IP address or url, and your router set to portforwarding to the youless.
Give me a DM if you want to do that.

v4.3.1 was just released as test: Youless and Enelogic | Homey

  • youless@2.7.1.
  • Fixed compatibility with Youless firmware ^1.6.0.
  • Fixed HP2023 compatibility.

@Jelmer_Knuivers @JosB can you please test and let us all know?


I have installed the test release and I can confirm that it works! Thank you for your quick response and fix!

1 Like

Today my meter got replaced by a new KAIFA with DSMR 5.5. (I’m using a 3 phase connection)
Youless = 2.0.3, Firmware = 1.6.0-EL, HP2023

Youless app on iPhone gives correct readings but Homey not. Reinstalled the app and device but no luck. Gives error: Poll error No connection with Smart Meter.

Till replacement all worked fine. Any idea?

You could ask youless support what is different when using dsmr5.5

But you say you are using youless 2.0.3? The current version is 4.3.1!
Installing that could solve it for you.

Sorry 2.0.3 is the iPhone app version. The app on HP is on 4.3.1.

Issue is fixed :thinking:. No idea what did it but around midnight it started to work. (Was not working from 15:00 when they replaced the meter)

1 Like

Maybe the meter itself needed to be configured by the netmanager.