[APP][PRO] Yamaha AV & MusicCast Receiver

I tried this:
curl -X POST http://172.16.XX.XX/YamahaExtendedControl/v1/main/setAdaptiveDrc?enable=true
and it seems that nothing happens :frowning:

However, I tried to do some packet capture between yamaha iOs app and my receiver. And I’ve got this:



Host: 172.16.XX.XX:80 
Content-Type: text/xml; charset=UTF-8 
Connection: keep-alive 
Accept: */* 
User-Agent: AV Controller/5.60 (iOS) 
Content-Length: 154 
Accept-Language: en-GB,en;q=0.9 
Accept-Encoding: gzip, deflate

<?xml version="1.0" encoding="utf-8"?><YAMAHA_AV cmd="PUT"><Main_Zone><Sound_Video><Adaptive_DRC>Auto</Adaptive_DRC></Sound_Video></Main_Zone></YAMAHA_AV>

Is this info helpful?

Nice, I’m sure I tried this, too, but without success.

The XML message is the old API (AV receiver).
Which device did you add to Homey? AV receiver or MusicCast receiver?

Yeah, it is usefull! Now I can do this to enable AdaptiveDRC:

API call looks like this:
<YAMAHA_AV cmd="PUT"><Main_Zone><Sound_Video><Adaptive_DRC>Auto</Adaptive_DRC></Sound_Video></Main_Zone></YAMAHA_AV>

It’s a Yamaha RX-V771 receiver. It’s from 2011 I believe.

Ok, if you are using this flow card, then you added an AV receiver device (not the MusicCast which uses the JSON API).

I can add this DRC option to AV receiver.

1 Like

New test version 1.1.8:

  • Added Adaptive DRC to AV receiver device.

@guglez FYI, you can test now :slight_smile:

1 Like

It works, thank you!


My receiver is brand new and using the Musiccast app all the time, but can’t add it in Homey.

The receiver is added with the receiver icon.

And another feature I was wondering if was possible.
In Sonos, there is a card where you can write your own text and the speaker will output that with an AI like voice. Is it possible to do the same with this?

Is it Homey that is making that voice as a sound file and sends it to Sonos maybe?

What happens when yut try to add the receiver as MusicCast device?
Not found? Is it turned on?
Have you tried a second time. Sometimes the network check doesn’t see all devices in the short interval.
If it’s not found, try to set the IP address in manuel pair view.

And TTS is not possible with Yamaha. That needs a devie with online TTS transcription like Chromecastor Alexa. I think Sonos is using some kind ot TTS service in the background.

I think it is possible. Yamaha needs to be able to play a mp3 link which contains the tts voice message. I know my receiver can do that, just not with this Yamaha app.

Playing MP3s is only possible with DLNA. You have to browse the directories and select an artist/song. You can’t just cast an url.

Hi @RonnyW ,

Your app works like a charm with this one:

I discovered one thingy with the morning routine flow:
when I set the volume with a variable, and the value is wrong, the volume gets set to 100% :hear_no_evil::face_with_hand_over_mouth: without any remorse.
So, me and the neighbors woke up real quick! :crazy_face:

What happened:
I did not pay attention and entered volume level 30 instead of 0.30 as variable value.

I think it’s more convenient to let the app set the volume to zero, or just don’t change it, when a out-of-limits value got set?

Thanks and cheers

Hi Peter,

hehe, with this receiver you were lucky that the walls are still standing :smile:

The volume card is the standard Homey card.
Did you assign a token/variable here?


I think all I can do is to check for a value > 1 and throw an error.

Edit: I checked in debugger. Homey just transfers 1 to the app if you are inserting a higher value as token. So I can’t reallly check it. It is like it is :man_shrugging:

1 Like

The receiver devices will show up in speaker widget in mobile app soon. Thanks to Athom to add amplifiers.



Thanks, Ronny.
Yeah, this thing is mf LOUD hehe.
OK, so I think it might be a better idea to let it start up with it’s programmed power-on volume level, instead of using flowcards with values from variables. Let’s stick to lights with that approach :sweat_smile:

Thanks for looking into it!

You can use tokens, but you have to use the Homey range from 0 to 1 (for 0…100%).
The app converts this value internally to your receiver volume range (can be different for every receiver).
I use standard Homey capabilities to be compatible to other devices. I tjought about adding a second volume flow card for the “real” value but I had rejected that because I would be irritating.


My RX-V6a has been working perfectly with your app up until about 17 hours ago.
I noticed that Homey had a software update this night, so I presume this might have something to do with it?

The IP-adress is still correct, and I haven’t changed anything in my settings.
However, it shows the red warning sign and can’t connect, telling me to check the device’s IP settings in the settings.

Is this a familiar problem and does it indeed have something to do with the recent update by Homey?

I have no idea. The app is working without issues here and I got no other messages about connection errors.