[APP][Pro] Bluesound - Multi-room Music. The Hi-Res Way


Bluesound for Homey

App Store Page: Bluesound App for Homey | Homey


Bluesound is an award-winning wireless hi-res sound system that lets you play music in any and every room throughout your home. With this app you can use Homey to control your Bluesound devices.


Add the device as you would add any device to Homey. Enter the IP address of the device (can be found in your router or the settings of the device itself), the port it listens to (default is 11000) and the polling frequency (default is 100). The polling frequency is not related to the update frequency of data in Homey, as this is almost immediate, and therefore can be left at the default to reduce network traffic.


v3.2.8 - 2023-10-23

  • Fix minor crash when image could not be updated.

v3.2.7 - 2023-10-08

  • Fix crashes.

v3.2.6 - 2023-04-18

  • Correctly handle numeric metadata.


  • Connection test on new device creation.
  • More (minor) improvements to album art display.


  • Added eslint checking and fixed all warnings.
  • Improvements to album art display.

v3.2.3 - 2022-11-12

  • Implemented long-polling.
  • Back in app now executes back on player only once instead of twice.
  • New app image.

v3.2.2 - 2022-11-10

  • Dealing correctly with players set to fixed volume level.
  • Muting uses player native muting functionality.
  • Deprecated custom repeat, shuffle and set relative volume action cards, as they already exist natively.

v3.2.1 - 2022-11-07

  • Album art display fixes for streaming services.
  • Improved logic for album, artist, and track names.

v3.2.0 - 2022-11-06

  • Now showing track, artist and album.
  • Added album art display.
  • Implemented shuffle and repeat functions.
  • Fix for crash when service was unknown.

v3.1.0 - 2022-11-04

  • Fix: Correctly handling playing/non-playing states.
  • Upgraded project structure to Homey Compose.
  • New maintainer.

v3.0.8 - 2022-02-07

  • Bugfix for the app crashing.

v3.0.7 - 2022-02-04

  • This release contains no functional changes but only updates for used framework due to security issues.

v3.0.5 - 2021-02-22

  • Updated to SDK3 (require Homey firmware 5.x)
  • Fixed an issue with the start/stop playing trigger card
  • Removed a duplicate “is (not) playing” condition card. You might have to update your flows because of this.

v1.3.6 - 2020-06-25

Another fix for issue with start / stop playing trigger cards.

1.3.5 - 2020-06-23

Fixed issue with start / stop playing trigger cards.

1.3.4 - 2019-12-11

Fixed issue with relative volume action card.

v1.3.3 - 2019-11-15

Moved installation instructions from app store to community support topic.

v1.3.2 - 2019-05-04

  • FIX: fix for relative volume action card

v1.3.1 - 2019-04-18

  • NEW: relative volume action card

v1.3.0 - 2018-02-07

  • FIX: improvements to pairing template for firmware 2.x
  • FIX: removed experimental card for switching input based on user input
  • FIX: code refactoring in driver (replace callbacks with promises)

v1.2.7 - 2018-12-14

  • NEW: action card for changing input to next or previous input
  • EXPERIMENTAL: action card for changing input to a given input (will switch through inputs until given input matches the switched input)

v 1.2.5 and v1.2.6 - 2018-09-21

  • FIX: fixed a bug after refactoring
  • REFACTORING: switched from request node module to node-fetch (reduced footprint from 7MB to 500kB)

v1.2.4 - 2018-08-22

  • UPDATE: updated app manifest to include id of new forum support topic
  • UPDATE: updated node packages to latest versions

v1.2.3 - 2018-06-09

FIX: fix the is (not) playing condition card

I’ve added my NAD T777 v3 as a device, It can connect, but after 1min or so it becomes unreachable.
Have to remove it, and ad it again, but then it becomes unreachable.
This behaviour came with the latest update.
Any thoughts?
I can reach the unit with my browser without any issues.
(wired connection)

Hmmm, I don’t own this device myself so I can’t test updates. I have updated some node modules, perhaps there is now an issue with one of these node modules resulting in connection issues. Do you know how to do a CLI install. I could create a custom version which shows more logging and point me in the right direction.

Never done it, but a quick google gave me this:

How hard can it be :slight_smile:

I currently dont have time to make a version which spits out debug logging but you could already try with the current version. Perhaps it already shows an error.

EDIT: It worked for 5min this time with the version on github, now the unit is unreachable again

I have created a branch on Github with extra logging. Use the CLI install and the ‘athom app run’ command to run the app. You should then see the results in the console which will hopefully tell us what is going on,.


well isnt this typical, the branch u created works like a charm.
No drop outs since I installed it.

I haven’t changed any functionality in this branch. My guess is that it was a network hiccup of some kind. You should install the app version again to receive future updates.

v1.2.5 beta - 2018-09-08

REFACTORING: switched from request node module to node-fetch (reduced footprint from 7MB to 500kB)

I have released a version in the beta channel which reduces the size of the app a lot. Functionality has not been changed. But since I dont own a BlueSound device myself I can not test these changes. Could someone install the beta and let me know if everything is still working. Thanx in advance.


i’m on the beta channel on the 1.2.5 version. But my devices keep stating ‘Unreachable’ while if I visit the device via the browser, its perfectly working:

I tried restarting Homey and the app, but both of my bluesound devices keep being offline.

Are you familiar with command line installs? It would help a lot if you could run the app from the command line and tell me what the console says. Please use the debug tree for this on the apps repo.


Hi, i’m not familiar with the command line install. Is there any other way i can debug it?

Find somebody else who is familiar with the command line or get familiar with the command line … :thinking:

Not really, this is the down side of creating an app without actually owning the device.

:frowning: then i’ll need to find time to do so I guess.

where’s the cmd line guide? :slight_smile:

While i didnt had time yet to do the cmd line test. I did try to add the device again and it gave me this error in the network console when I press the test-connection button:

btw. will a VPN to my network help you out testing?

Thanx, this points me in the right direction of the bug which has been causing the issues with the beta. I will release a new version with a fix soon.

v1.2.6 beta - 2018-09-21

  • FIX: fixed a bug after refactoring

Could someone in beta test this and give me some feedback it work now.