[APP][PRO] Yamaha AV & MusicCast Receiver

New test version 1.1.2:

  • added flow action for scene selection (1-8) for MusicCast devices

@hreba,
The live version is waiting for approval, but you can already try the test version.

1 Like

Thank you, I will check tonight, but I expect it will be fine :wink: I just noticed Select scene is available for MusicCast Receivers (+Zone), but missing in AV receivers. Just letting you know, maybe it’s as it should be :slight_smile:

Well recognized :slight_smile:
I hadn’t thought about the old devices anymore, but their API also allows you to set the scene.
I’ll add this in the next version…

New test version 1.1.3:

  • added flow action for scene selection (1-8) for AV receiver devices.

Hi Ronny, It might be me but I noticed after one of the recent updates that I am not able to change the input on Zone 2 using a flow. However I am am able to change the Zone 2 input through the Device. The receiver is the RX-V6A which supports seprate inputs for the Main and Zone 2. I was wondering if you had any thoughts?
Thanks,
Matt

Hi,

I might just be looking over it. But my receiver has the “all ch. stereo” option. I can’t find this in the “select surround mode” node. Only 5,7,9 and 11 ch. stereo, but it doesn’t know what to do with those settings.
Besides that, “surround decoder” auto sets it to auto mode. Is there a way to make it pick “surround decoder and select which surround decoder you want to use?”

Thanks!

You are right, The zone is missing when the device is changed via flows actions.
I’ll provide an update soon.

Can you please recover the receiver features using this URL (using your IP address):
http://IP/YamahaExtendedControl/v1/system/getFeatures
Please send me the JSON content (PM). Then I can check what programs your receiver supports. Perhaps there is a new program that’s currently not added to the dropdown list.

What exatcly is meant? Can you show with a screenshot what you try to select? A surround program?
If it’s the “Surround Decoder” entry in surround mode list, then there is no other possibility. The receiver should recognize the needed surround settings automatically based on the input (cinch input with 5.1 signal Dolby ProLogic II?)

New test version 1.1.4:

  • Fixed zone selection for flow action of zone devices.

@Matt2 Can you please check the test version, if it’s working now? Thanks.

Hi, I’m not really familiar enough with json etc. To be able to make any sense out of what to do with the info I get when opening the link.

What I meant was the “surround decoder type” in the image I added. It let’s me pick a certain one besides having it auto pick.

Above the image with the first few of the programs. There’s more below, but I think I found most of them on there and don’t really use them anyway.

Just copy/paste the output you get in your browser and send it me as private message.
I can check what features your revicer supports.

New test version 1.1.5:

  • Added flow action “Select surround decoder” for MusicCast devices/zones.
    I only found surround decoder settings for the MusicCast API. For AV/XML API I haven’t found it yet.

grafik

@LexvV
Can you please check the test version?

Awesome, that’s exactly what I meant :slight_smile:

DTS NEO Music is what I was after for some music listening :slight_smile:

Let me check if I can sent you the output of that link you gave me earlier.

New test version 1.1.6:

  • Added ‘All channel Stereo’ sound program for MusicCast devices.

grafik

@LexvV FYI

All is working correctly now. Nice job. Thank you

New test version 1.1.7:

  • Added flow conditions for input and surround program

@DoctorBazinga
FYI and test :slight_smile:

Is it possible to trigger Adaptive DRC via this app? It can be usefull when someone is watching movies late in the evening so the DRC can be turned on automatically.

I haven’t found DRC in the API documentation. But I’ll check other sources.

Can you please check if this API call works on your MusicCast device?

http://[RECEIVER-IP]/YamahaExtendedControl/v1/main/setAdaptiveDrc?enable=true

Just exchange [RECEIVER-IP] with your receiver IP address and try teh parameter true/false.
I found this in a HomeAssistant forum, but it doesn’t work for me.