[APP][Pro] Xiaomi Mi Home App

Sorry if this has been brought up earlier, which I think it has, but I couldn’t find anything when searching the page with my smart phone.

I am testing to add a vacuum cleaner but that app does not recognize the token, which I know is correct.

Do anyone have a clue?

Also, when I retried this, I get a different error message (couldn’t find pairsession, which I suspect is that it couldn’t find the device at that time?)

I restarted the app and tried again, and get another error message.

I assume my vacuum robot is not supported, which maybe isn’t that strange. My robot is of a sister brand to Xiaomi, a Dreame L10 Pro. It has not an android app of it’s own, it uses Xiaomi’s Mi Hole app just as a roborock or Xiaomi vacuum robot.

Anyone here that might know a solution or even have a Dreame D9, L10 Pro or similar robot from Dreame?

You can ask the developer if he is willing to add the device to the app. His telegram profile is listed in the comments somewhere in this topic.

Yes. Vacuum-mop p chinese version does same. It means it not supported or running through xiaomi cloud.
Installed HCS per installer on windows and Xiaomi mi homey app 1.1.2 from Homey community store . Both 3H purifier and vacuum-mop p work :grinning_face_with_smiling_eyes:

Hi @Maxmudjon ,

I am not sure if this the right place to ask my question but I wanted to install Qingping Air Monitor Lite.
Qingping Air Monitor Lite

I think that this sensor is the successor of the PM2.5 Air Monitor. I have added the new sensor to HomeKit but want to use the data in Homey.

It look like that it is not possible yet to add the sensor to the Mi Home app.
Will it be possible to add this sensor to the app?

Thanks for the support.

1 Like

Are you been able to connect the gateway ZNDMWG03LM? It seems like it is able to connect it with the Mi Homey app. Im curious if it works and if you been able to connect bluetooth aqara sensors to Homey.

See also my post: Mi Homey - #264 by UA84

Heeyy Guys,

Anyone know if the Xiaomi SmartMi 3 Standing fan is being supported in Homey? I have installed the app and tried both available versions but neither work :frowning:

If I can do anything to help please let me know so I can do something back for everyone.


Anyone is unable to add Roidmi Eve + vaccum in Homey ?
When i want to add, i have the error ‘device.getState’ is not a function.

I already send an email to the developer, but i don’t have any response.

Thanks for your help.

1 Like

It means the device is found but not supported. You could try to add it as one of the other vacuumrobot devices to see if that works.

Hi @Da_JoJo,

Thanks for your answer.

I tried with the Xiaomi Mi Home app, and add Mi Robot Vacum Cleaner
What app are you talking about when you state “vacuumrobot devices”.

The other types vacuumrobots in the list when you add the device. Like you have a vacuumrobot mop p and add it as a vacuumrobot lds. Or in your case the roidme as a xiaomi vacuum for example. Or as roborock.

I’m trying to add Mi Smart Humidifier v1, and I get one of those errors:
Could not find that PairSession
device.power is not a function
Could not connect to device, handshake timeout

I tried to find out what can be a problem and I found out that miio seems cannot find token, because it shows “???” But I managed to get token with another app. So I wonder if miio cannot find token, does it mean that this model is not supported?

1 Like

+1 for the Xiaomi Kettle? I can’t find it in any app or device to add.


Two of my devices, a humidifier and and air purifier suddenly show up offline. I’ve tried re-adding them in mi home, getting new token, etc, but they still show offline. Whereas another one of my humidifier still works with homey. If I try to add the non working devices again on homey, I get the “handshake timeout” error. All 3 devices work fine with mi home app. Any clues?


I have a same problem as @kalpik. My device (xiaomi roborock vacuum) was offline for months but I didn’t want to find the new token.
Yesterday I finally tried it. iBackup Viewer seems to show the token in the app… which seemed odd to me but I did the whole .db extraction and stuff. Same token. But it wasn’t accepted.

I did a wifi reset on the vacuum. There is a new token but when adding a new device the “test connection” button isn’t even working…
What is going on?

Well, I have since then solved my issue. It was because Homey and the Xiaomi device were on separate VLANs. This is the exact issue: Some devices not responding across subnets. · Issue #422 · rytilahti/python-miio · GitHub

And I solved it in my router (OpnSense) using hybrid outbound NAT: Some devices not responding across subnets. · Issue #422 · rytilahti/python-miio · GitHub

Good for you!

Mine are on the same network, so I hope someone has a solution or something!
Although the “test connection” works, but says “could not find that PairSession” (?)

Have you tried the HCS version:


Hi all,

I’m wondering if this Humidifier ZNJSQ01DEM XiaomiProducts | Xiaomi Mi Smart Antibacterial Humidifier - XiaomiProducts will work with this app.

I see that Xiamomi Humidifier v1 & v2 should work, but I’m not sure if v1 or v2 is the above humidifier.

I did some searching on Google, but sadly I can’t find an answer.


In the description (under your link), I found this line:

De Humidifier is ook te integreren in Homey.