Yeelight not working


Since a few days, all my Yeelight lamps, the WiFi color version, are not available in the homey. Do more people suffer from this or do I perhaps do something wrong? Could someone help me?

On the iPhone app Yeelight, they work normally and lan management is also on.

Thanks in advance for any responses,

Yeelight support has been removed from the following app:

And is now supported in a separate/new app.

If you are still using the old app, remove lights and add them with the new app.

Always read the changelog before updating:
“Support for Yeelights within this app has been deprecated. Yeelights are now supported through a dedicated app available in the app store. Please migrate your Yeelights to the new Yeelight app.”

very thanks for your answer. I already tried to connect them with the new app. But the homey yeelight app can’t find any yeelight. Do I need to reset the yeelights to factory default? I try tonight.


Reading material:

Thanks but still it doesn’t work.
LAN is on in the Yeelight app. In this app the light works. But when I want to add a light in homey. She said that there are no new devices found.

Have you removed the Yeelights from the Xiaomi Mi Home before trying to pair them with the Yeelights app?

No i didn’t but now I deleted the whole (old) app now from the homey.
And I reset the light.
Connect again with Yeelight iPhone app
Set LAN control ON

Still no new devices found in the Yeelight app in the homey.

Seems the way to do it right?

Thanks anyway

Deleting the app does not remove the devices. You need to remove them. Due to a bug in Homey (which will be fixed with firmware 3.2.0) you can not have the same device paired by two different apps.

Thank you. So I had to wait for 3.2.0?
There are no devices in the old app. See screenshot

Hope there is a solution.

No, you probably have to wait for version 1.0.3 of the Yeelight app which contains some fixes for pairing certain lights (specifically the ceiling5 model). It’s pending approval and wont take more than a couple of days maximum.

Ok. Thanks for now. I come back when the update is released.

Still the same with the update. No new devices found or time out error 30000ms.

Very disappointed because I have 8 of the yeelight color and it works before the app changes.

IN my case I had to factory reset my lights (in this case Yeelights LED strips). Looks to me product / firmware issue, as it started already some time ago.

Thanks, I already tried but still no new lamps showing in the homey app.

@athom homey
Maybe there is a way to delete the yeelight app and restore the old xiaomi mi home because the new yeelight app is not complete and fully tested. Next time it’s better to bring a beta version first.

The lamps Works in the yeelight iPhone app.

@Randy_Kl I’m sorry you are experiencing issues. But out of +100 users you seem to be the only one which still has issues. So I would not directly blame the Yeelight app. The code of the new Yeelight app is pretty much the same code as the Xiaomi Mi Home app. Saying the code is not tested properly is just pure nonsense because of this. And even if that was the case, I’d create these apps in my spare time so a little respect for the effort would be nice.

But enough of that and lets try to figure out what goes wrong. First question, is your Homey on the same (sub)network as Homey? And do you know how to run an app from the command line, you could run the debug version of the app and that would tell me what is going on.


yes it is in the same network. I factory reset my homey but it doesn’t work. I don’t know hoe the cmd line question works so I can’t

Is it maybe because my lights are updated to firmware 2.0.6_0065?

My new Yeelight ceiling type YLXD18L (50W) is also not working in Homey.

  • installation correctly
  • in Android app all is working
  • LAN control is switched ON
  • Xiaomi app was never used before
  • firmware lamp just updated to 1.5.9_0053
  • Yeelights app in Homey: after adding device, mostly message appears “no devices foumd”, sometimes “timeout 30000 ms”.

Is there already a solution?

  • I tried resetting router
  • I tried reinstalling Yeelights Homey app.
    So far no luck.

Is the light on the same VLAN as Homey?

It’s an new router, nothing setup except some passwords.
IP-address router:
IP homey:
IP yeelight:
No VLANS are setup as far as I know