All my yeelight Lamps are lost every few days

Hi, I am using the official yeelight app on my homey pro 2023.

I connected all yeelight Lamps zo my yeelight app (EU Server) and connected my yeelight xiaomi account to the homey yeelight app.

Everything works great, simplest example: Press an ikea styrbar remote control and kitchen light turns on.

After around 2 days the homey app tells me the connection to yeelight is lost. I can „repair“ it and import all lights again but then i have to rewrite all flows for me yeelight.

Then, again, it works great but only 2 days and the same procedure repeats.

Any idea what might be the reason and how i could fix it ?

The original android yeelight app works great all the time, only the homey connection has this problem.

I think you´ll have to write to Athom (as well), the app creator ánd the Homey (cloud) creator.
App support links are present at the app store pages:


Btw, if you ever need to repair multiple flows again, try this neat script

1 Like

Check if the Yeelight lamps have a proper Wifi connection. I’ve had similar issues in the past (also with the Yeelight LAN app), with a few lights that were located a bit further from the WIFI access point. After adding another AP everything has worked fine for a while now. I also had the same thing the Yeelight (and Xiaomi app did work. What worked most of the time as a workaround (before adding another AP), switch the light off with a switch (not through the app), wait 2 min, turn it on again, seems it will then try to reconnect.

And yes, it can also be something else (like a bug in the app), but this might be easy to check