[APP][Pro] Xiaomi Mi Home App

@Phuturist @Sharkys

My commitment is fulfilled. Just donated 15 euros through the PayPal app as @Phuturist committed himself to update the app. Great news!


I will do a donation this weekend as well!
And can test some wifi devices such as purifier and humidier.
And maybe the Xiaomi Vacuum STYJ02YM?
It works via a workaround in the Roborock app but the developer is not active anymore.
And in the current Xiaomi app i can’t connect it.

1 Like

Maybe opportunity for @Phuturist fro another app ? :wink:

Thanx to all who donated, it’s much appreciated … :pray:

I’ll be on holiday the upcoming week. The week after that I will release the first test version to the test channel. This release contains the following:

  • Upgrade to SDK3
  • Merged with the Mi Homey app from the community store, all devices will now be available under one app (this requires re-pairing of those devices)
  • Support for a couple of extra devices from pending pull requests from the Xiaomi Mi Home repo
  • Couple of improvements to existing drivers
  • Possibly tested on Homey Pro 2023 but I havent had time to set that up yet

Since it’s a complete rewrite it could be some devices need to be re-paired or flows need to be fixed. There was a lot of duplicate and not optimized code in both apps which I cleaned out. Something that ment breaking currently functionality to make it more future proof.

When all is stable I can consider added missing devices where the information of these devices is available somewhere on the internet.


Is there a possibility that “room”-cleaning can come to the app?

What do you mean by this, like vacuum robots ?

But also

For instance. The Xiaomi Mi Home or Mija eco system is huge and they keep bringing out new product variations that work slightely different all the time. Some products have been reversed engineered and integrated in other integrations. Sometimes this information can be used to add it to the Homey app as well. But as mentioned, I first want a stable base (SDK3 with merged functionality of Mi Homey).

I already looked at that if integrating those would be an opion, the code of this app is not shared on Github by the developer as far as I checked so no, I probably wont be integrating that 1-on-1.

1 Like

2023-03-05 - v3.1.0 - TEST

This release is a complete rewrite of the app including many breaking changes. The app has been fully rewritten with SDK3 to make it futureproof. This new version also merged the devices from the community app Mi Homey. Some previously paired devices might continu to work but please re-pair your devices and/or fix your flows before reporting any issue. If the issue persists after re-pair please report it on the community forum or Github.

I have just published version 3.1.0 to the test channel of the app store and I’m looking for people to properly test this version as it will contain bugs. As the release also contains breaking changes the only way to properly test it if you encounter an issue is by re-pairing the device and/or fix your flows and test if the issues still persists. If so, please report it here or preferably on Github.

If you want to go back to the live version you will have to re-pair and/or fix your flows again as both versions are not fully back- and forwards compatible.

The test version can be installed through this link: Xiaomi Mi Home | Homey

1 Like

Thank you @Phuturist , going to test for my few devices.

ALL - just might this script come handy : [HOW-TO][Pro][Cloud] - Tool to FIX (advanced) flows after removing and re-adding devices

It’s fantastic life saver in such situations. My advice - mark down the old device IDs before doing any repairs. :wink:

1 Like

So surprisingly Xiaomi Gateway v2 (lumi.gateway.v3) added flawlessly (previously added as 3 devices, now as one) - I see however JOIN button missing (eg. when adding devices to the GW itself). Surprisingly even lux sensor works after more then 2 years ! :wink: Not sure if light powered off via DIM or powered on via DIM shall results also in Button switched off/on- it’s currently independent on light itself but button itself turn lights on/off.

I also got down-light “Philips” lights but after adding them (and also after automatic app update), I’m getting error when interacting with light - Could not get device by ID …sent also diag report f5c3c1ea-9865-4e90-8559-2c82d433ae62 (I hope that’s the right one from clipboard but if not, i guess you were notified)

Where is this button supposed to be? I thought adding devices to the gateway was done in the Xiaomi Mi Home smartphone app. I can probably add it if I know where to look for.

Havent really looked into this level of fine-tuning. If it’s desirable you can add it as feature request on Github so I can look into it at a later time. First make it stable.

Yes, got the report and know what’s wrong. Will fix that with the next update.

1 Like

I had it available from the Mi Homey app v 1.1.12 - in device type named “Gateway | SOME_HEXA” (this is the name when added the GW) - GitHub - Maxmudjon/com.maxmudjon.mihomey: MiHomey App for Athom Homey or better com.maxmudjon.mihomey/driver.compose.json at master · Maxmudjon/com.maxmudjon.mihomey · GitHub

It’s far from anyhow important, it’s just consistency maybe - I’m any way handling it via flows, I guess that error existed even before.
Both created as Xiaomi GW v3 - Join button missing and dim values are not changing button on/off state · Issue #159 · jghaanstra/com.xiaomi-miio · GitHub

Awesome, thank you. :wink:

Wow… :index_pointing_at_the_viewer: :+1:

Like I said, a complete rewrite … :wink:


Is it any chance that Roborock S6 and above will be included in this rewrite, since Justine Harings Roborock is abandonded? :heart:

Maybe spkesDE will (re)create one, as he owns Roborock - S7…

But it’s true that in the current app you can add Roborock as well :

1 Like

I want to get a S7, but I don’t own one yet.

Ou, sorry…that’s a bummer. But definitively, a little bit of OT, I can really recommend Roborock brand - it’s based on 3 years of experience with it, great device, very reliable.

1 Like

The device can clean as it should. But return to dock not works anymore.
Tried one the device “property” page in the app. Also tried as part of a flow. No success.

What device? And on what app was it previously paired and with what driver? And what is the actual error. I need more info.