[APP][PRO] VThermo

VThermo can be used to control other physical thermostats by setting the set point up and down, but for that it needs the temperature reading from the physical thermostat.

In your case it doesn’t find that temperature, I guess.

But you can use VThermo with a temp sensor, and add two flows to control the Gree HVAC.

  1. WHEN: VThermo “Heating turned on”, THEN: control Gree HVAS (turn on).

  2. WHEN: VThermo “Heating turned off”, THEN: control Gree HVAS (turn off).

Thanks! I will try that. Will that method also support Tibber controlling?

@balmli : There seem to be a bug with the «heating turned off» card. When I select it, my Homey app goes all black… I have tried with two different Homeys, and get the same bug on both.

Yes, the mobile app goes black. But the web app (https://my.homey.app/) works fine, so there’s something wrong with the mobile app.

Try using the webapp until Athom fixes the mobile app.

1 Like

@balmli I use the VThermo to control my Mill ovens where I have set “Thermostat” under “Control devices in the same zone”. This works mostly fine. As this is in my cabin, I reduce the temperature down to 8 degC when we are not there.

What I observe is that some times the setpoint VThermo sets for my Mill ovens are to low for the Mill oven, resulting in that the oven setpoint is not reduced hence the oven steers towards the previous setpoint. Typical example is that the room temp (measured with a Aqara Temp and Humid sensor) is below the setpoint, 8 degC, the setpoint set on the Mill oven might be set as low as 4 degC. It seems that the lowest temp that Mill accepts is 5 degC.

So to the question, is it possible to set a low (and maybe high) level for the temperature VThermo set for the thermostats is steers?

I have been using vThermo for more than a year now, almost working perfectly. My primary usage is controlling cables in concrete floor where I don’t have sensor. Instead I am using a Aqara close to the floor and vThermo to control the switch. The only issue I have discovered during the use is it sometimes get “out of sync”, sometimes very warm or sometimes cold. This happens if there is a manual action on the switch. I think the solution to this is to introduce an extra check on temp every x minutes/hours. Please consider this @balmli

Moving to Homey Pro '23. Created a new VThermo device but cannot save any settings because an error is thrown “Invalid Capability: target_temperature”.

Steps to reproduce:

  • create new VTHermo device
  • open settings
  • press save immediately: no error message.
  • open settings
  • change 'Temperature calculation method" from “Average” to “Newest” and press Save
  • Error: “Invalid Capability: target_temperature”

VHumidity isn’t registering my aqara temp/humidity sensor. it is in the same room but isn’t reading its properties. any suggestions? I had this working for years but with the new Homey Pro install it broke.

You must use the test-version v. 1.10.x for HP23,

It’s still work in progress, but I’m running v. 1.10.2 on two HP19s and one HP23, and it’s working fine for me.

1 Like

v1.10.2 TEST - same issue :smiling_face:

Using 1.10.2 with Homey Pro 2023 I discovered one of my zones where heating, even if the temperature was way above the set point.

From the event on the VThermo I can see it’s entering Idle state at 10.32 today

From the event on the Wall Switch I can see it was turned on at 10:25, matching the Active state, but the Idle state seems to got lost, so I dicovered it and manually shut off the swich at 14:37


Maybe the VThermo should discover this and repeating to turn off the Switch ? The Insigth from the Temp sensor is getting the increased temperature, and VThermo should be able to try a little harder to turn off the switch …

On -rc.61 I’m not able to recreate this issue

Hi @balmli ,
This is weird, I add a VThermo thermostat device, open settings, change the first parameter from average to newest, press save,… boom… Invalid capability: target_temperature…
I am also on rc61

Got an another incident where the VTherm is not able to turn off the power switch in current zone

When desired temperature is lowered, the switch is not turned on …

diag : fe524410-8a42-4511-a8a0-0911b222c452

Hi Bjørnar,
On v10-rc65 I have the same issue.
Would it help if I sent you a diag report? Would you have time to investigate?

Hi, After switching to homey 2023 VThermo does not get any temperature readings from any Fibaro devices. Is that a problem with new version ore did I miss something?

Yes, I see that this is an issue. Will have a look at it.

For HP 2023, you must use the test-version.

There’s and issue with it, but please be patient. Will be fixed.

Thanks, works perfectly.

Svein Arne Eggen

Hi Bjørnar,

Process before this diag was created:

  • reboot
  • wait a while 5-10 mins
  • remove old vthermo device
  • add a new vthermo device
  • in settings, tried to enable ‘Temperature sensors in the same zone’ - other thermostats in the same zone.
  • press save, then error:
  • image

Created Diagnostics ID: adc4f213-8b29-41f9-85d4-996c084ef1c6
on HP23 - v1.0.0.-rc65
using test version Vthermo: v1.10.2