[APP][Pro] TuyAPI / Neo Coolcam wall plug WIFI app

Hi @Rens_Brandwijk,

I tried to add a smart plug with metering, but got stuck in the pairing of your Homey app.

What Am I doing wrong?

Hi all

Well, I thought that it would be nice, to add some Zigbee Plugs zu Homey and ordered an ‘Nous Smart ZigBee Socket A1Z’ and some ‘Hombli Smart Socket’, since they both support Tuya.

In the mean time I setup an developer account at iot.tuya.com based on the instruction tuyapi/docs/SETUP.md at master · codetheweb/tuyapi · GitHub.

As I understand, the command line part (7.) is no more necessary and the ‘api key’, api secret (password), random devicekey and Region can put into the Homey App ‘Tuya v3.1.1’. This is what I did.

As soon as I’m trying to add the ‘Noun A1Z’ device in Homey Pro, I get the following error message in the Homey app:

  • 1106: permission deny

Just double checket all my setup, but can’t currently find the reason for this issue.

Any idea, how to fix this issue?

Hi @Rens_Brandwijk & Community

Still trying to solve my issue “1106: permission deny” while trying to add my first Zigbee device in Homey.

Some questions:

  1. What exactly do I have to add under “Random devicekey” in the Tuya Homey app?
  2. Am I right, that I should be able to add a Tuya Zigbee device to Homey Tuya app without using Smart Life or the Tuya Smart app?

I know, very basic questions… :wink:


I bought this product (Smart Life Tuya-Contrôleur WiFi RVB, ), and it is well installed on Smart Life, functioning correctly. I tried to install the Tuya application and follow the procedure, but it didn’t work. I find it complicated to set up. Additionally, Tuya blocked my Homey Pro 2023. Nothing was working anymore, even after restarting the box. I couldn’t even access the management console via a Mac. I had to delete Tuya through the iOS app, fortunately, it still worked. I was lucky because I thought I had to do a restore.

My question is: Is it really necessary to go through this procedure to use this product https://fr.aliexpress.com/item/1005005606019896.html?spm=a2g0o.order_list.order_list_main.28.68d65e5bF77il5&gatewayAdapt=glo2fra? I don’t understand why there is no Smart Life application. In fact, I will immediately request the creation of this application from support to access the product without going through all this cumbersome configuration.

It seems to be no support from the community for Tuya device integration anymore. I just decided to cancel the try to integrate Tuya devices into Homey Pro and I’ll send back the Tuya test devices.

The reason is a summary of different facts:

  • the Chinese Tuya cloud service doesn’t appear very trustworthy (e.g. due to strange password policies)
  • the Tuya app by Rens Brandwijk seems no more to be supported (that’s ok and part of the game)
  • the community doesn’t seem to be interested in Tuya integration (support)
  • the device firmware upgrades will be an issue in future (especially if there is no manufacturer gateway available)

The experiment was instructive, but not worth the extra effort in my eyes. :slight_smile:

The tuya app i made a few years ago only works for non battery powered wifi devices by using an old api codetheweb made.

There was a tuya zigbee app but integrating them in one app will be difficult because it uses different platforms.

I am trying to maintain the tuya app sonit keeps working over homey sdk updates and am using it myself.

The problem is that the api is kind of complex, the platform is not very open and we have thousands of devices that all work a slightly different way. And there is no way for me to test them all.
Also homey pro works different from homey classic and the sdk gets more restrictive with every iteration.

The biggest problem for me is time. I have a family with 3 young kids and a 50 hour a week job to provide for them and a home that i’m renovating.

I just dont have the time at the moment to work on this app on a regular basis

I have a Tuya ZY-M100 which is a WiFi mmWave presence sensor. There is an integration for Home Assistant available which does support this sensor. It seems to me that TuyAPI is pursuing the same goal. However the supported devices are very limited compared to the integration for HA.

Any plans to support the Tuya ZY-M100 sensor as well?

Thank you


Hello, I have extracted all kinds of ID, keys and uid from devices in Tuya IOT cloud.

But exacly what API Keys and Secret am I supposed to fill in under the setup?
I just want to add 3 sockets I have, I have tried with the Access ID and Access secret for my account. But adding just one random device wont let me add anything. And how am I to add more devices than one if I can only add one device ID…

Do I need to remove devices added via Tuya cloud app in homey in order to add it in this TuyAPI app?

Do I need to edit settings between each device add and change the device ID?

1 Like

Please i have same problem. give me a dummy guide

I have some Tuya/NEO COOLCAM Wifi Power Plug NAS-WR01W 3600W and I try to use them in Homey Pro 2023 and the Tuya app.

I have succeeded to do the settings in [Tuya IoT Platform] and added them into Homey. I can access the devices from this IoT platform and read data and give commands.

The problem is that Homey cant access them. Its a red triangle on the Icon and I get error message when I try to switch on/off. ”Device unavailable”

This is the only type of device I have in Tuya Smart.

Is this device supported by this app? Anyone that have succeeded?


I have to ask if this is the correct app for my device.

The device is a Lyfco airconditioner with support for Smart Life / Tuya (wifi).

How to integrate this into Homey?

I try to integrated IOT on homey.
I read and respected the instructions, so I arrived to linked my tuya app (on my phone) and IOT, my device (light strip) appair on IOT and tuya app.

but How to do to executed the line command as describe on the instructions? (and also the CLI tool)
I think it’s my problem to finish procedure of integration,
Thanks in advance

Someone have an idea about this?
Thanks in advance

I don’t recognise those instructions.
The Tuya Cloud iot instructions can be found here

as linked to at the app store app page.

hello Peter,
No not by the tuya cloud, I talk about this

Ah I see.

This worked for me

  1. First, acquire API credentials by following this guide (https://tuyaapi.github.io/cloud/apikeys/). The process should just take a few minutes.

  2. Next, install the CLI tool by running
    npm i @tuyapi/cli -g

If it returns an error, you may need to prefix the command with sudo. (Tip: using sudo to install global packages is not considered best practice)

  1. Run the following command to get a list, in which Name, ID and Key of your Tuya wifi devices can be found:
    tuya-cli wizard

I found this tool as well, did not use it though:

anyway, if I tried to do with app tuya cloud, I 've an error message
I join the screenshots of IOT and APP homey with error code
(I try to include light strip “nous” wifi)


On IOT , the light strip is online, I suppose it is alright


Where is my error?
I put on homey, the user name and password of phone’s tuya app,
The telephone country code seems good (france for me so code is 33)
my phone’s app is tuya

Could you help me please :grinning:

ok, but how to do to install the cli tool by running? :face_with_raised_eyebrow:

Screenshot from 2024-05-21 00-43-44
OK, a clear error is always nice

As far as I can see on this screenshot: because the username can’t be an emailaddress,
you probably did enter your username, and not the email address you registered the TuyaSmart app with. You can find it in your password manager, or in the TuyaSmart app at Profile > Home management > “Your Home Name” > Home Owner

Why is the field called ‘username’ then, you might ask, I don’t know;
but the example in the Tuya Cloud post shows it:
Screenshot from 2024-05-21 00-45-33

> For Tuya Cloud app, the error codes also are present at the Tuya Cloud app topic I linked to:

OK, about the local Tuya keys:

Aahh, you’re probably not using linux OS
Here is ‘how to CLI’, this should help you install it on a Windows machine: [HOW TO] CLI install method

hello Peter,
many thanks for your return, it’s works fine.
My error was the username as you say
:+1: :+1: :+1: :+1: :+1: :+1: :+1:

1 Like