[APP][Pro] smpl products - Battery powered e-ink display

My apologies, I literally had five different cables I had tested that I was certain would be data cables but today I went to the store and bought a new one and finally I had some progress (alas, I was wrong about the previous cables, sorry!). Now the program will identify the smpl device, and it takes me to a step where it wants me to unplug and plug in again, but after that I get an error message as pictured. I’ve tried with all three displays I have and I get the same error with all. @Nitramevo, any advice to offer here?

Delete program/reboot/re-install/retry

I found the reason by looking through the logs, and I saw this:

2024-06-07 23:13:40.7238|Trace|Log message received: Error: Database cannot be found. DatabasePath = C:\Users\Administrat�r\AppData\Local\Temp\SMPL_Mini_Display_Update_Tool\lib/../Data_Base/STM32_Prog_DB_0x495.xml | 

Seems the home folder for the user I was using (this is a loaner laptop) was “Administratör”, messing things up with the non-ascii character there. I created a different user without “ö” and could successfully update all my screens. Back in business! Feels great, thank you for the help.

2 Likes

Yes, so glad it finally worked for you!

1 Like

I did everything

updated the firmware to the latest version on my SMPL displays and updated Homey Pro to the new version. Reset everything, integrated 3 Lidl Zigbee wall plugs and the displays still can’t be connected to Homey anymore

I am having the same issue as @Matthias_1

4 Likes

Everything is working again for me now.

I reset the Zigbee network to do this.

After that, I removed the batteries from the SMPL displays for a few days.

Then I added them again using the “Add new devices” function in Homey. Homey recognized the devices as existing devices and reconnected them. Now they are working reliably again.

Setup:
In my Zigbee network, I have installed several Lidl Zigbee sockets and the latest version on my Homey Pro, as well as flashed the displays to the current version.

1 Like

I have two of these devices. Every time I change the batteries, they are next to impossible to get back on my otherwise well functioning Zigbee network. They have firmware 1.17. The site lists 1.17.2 as the latest firmware so I wanted to try and update. However, midway through the writing process, the error is “Failed to program the wireless stack…” So now I have voided the warranty *), and bricked one of the devices. Any ideas how to complete the firmware update or get the device out of “DFU in FS mode”?
I have tried two different PCs, two different micro-USB cables. Same error.
*) not that the warranty would have been any good as per the status of the manufacturer above. I am sorry to read the status of the product and the development setup’s fate in Kharkiv.