[APP][Pro] Scinan and Saswell Climate Control

Saswell and Scinan Controllers

Testversion: Scinan and Saswell Climate Control | Homey
Live: Scinan og Saswell Klima Kontroller App for Homey | Homey

Support wifi climate controllers using the Scinan or Saswell API


Support wifi climate controllers using the Saswell API https://api.saswell.com.cn


Support wifi climate controllers using the Scinan API https://api.scinan.com.

Supported Devices

It seems that this app will work with any device that make use of the Scinan or Saswell Api and/or the Smart-E / Thermostat app on Iphone/Android

There are probably more devices supported. Open a issue and I’ll try to find out.




  • PST50W

Pergo QuickHeat


Supported features

  • :white_check_mark: Turn On/Off
  • :white_check_mark: Set Away/Home
  • :white_check_mark: View/Set target temperature
  • :white_check_mark: View mesured tempature
  • :white_check_mark: View/Set mode (Comfort, Day or Night or Auto)
  • :x: Program

Supported Languages:

  • English
  • Norwegian

Release notes


  • Corrections in descriptions


  • Corrected the “forEach is not a function” during pairing
  • Fixed so token again will be obtained from scinan.
  • Rework of the app, it should now work with the V2 Saswell API (Thermostat App from Saswell)
  • Added two new standard devices. Scinan using API v1 and Saswell using API v2


  • Added Norwegian Locale


  • Added support for Homey Energy
  • Fixed sync


  • Small fixes


  • Added mode


  • Initial

If you have problems with your devices not responding in the Smart-E app or the Homey app, you may need to switch to the Thermostat app from Saswell.

To do this, you need to create a new account with the Thermostat app and follow the instructions for your device.

Heres the instructions provided by Profag, also relevant for Pergo Quick Heat
Aktuelt (profag.no)


Procedure for switching apps:

  1. Make sure the controller is offline in the Smart-E app, but the Wi-Fi symbol is still displayed on the controller’s screen.
  2. Download the new app: Thermostat 6.1.8 from Saswell, available where you download apps.
  3. Register again using your email address and password in the Thermostat app. (see link below)
  4. Open your email inbox and activate your account by clicking the link in the received email.
  5. Put the controller in AP mode (press and hold the OK button for 3 seconds).
  6. Then, connect your controller in the same way you initially set up the system (tap on the (+) to the right of “overview,” find your controller’s SSID in the network list on your phone, tap on it, then go back to the Thermostat app and tap “start configuration,” followed by “try it now”).
  7. Back in the Homey app, enter your devices Maintenance mode and do the “try to repair.”
    important: after you completed the above steps
    This should change your device to apiVersion 2, allowing you to keep your flows.
    Optional. You can just Re-add your device in the Homey app using the Saswell Driver.

iOS: Thermostat on the App Store (apple.com)
Android: Thermostat - Apps on Google Play


I have installed the app [APP][Pro] Scinan and Saswell Climate Control, but when I try to add a device the app disappears from the list of installed apps, it shows for only a second and then disappears.

Hi Ivar!
And welcome to our community! :slight_smile:

I just updated the app to v. 2.4.14 please let me know if you still have issues.

Hi @ARTTU100

If you’ve previously added devices using the Smart-E app before April, refer to the guide to get those devices working again.

Otherwise, install the Saswell’s Thermostat app, create an account, and connect your devices. Then, use your Thermostat app credentials to link your devices to Homey.

Regardless of the method, start by setting up an account with the Thermostat app, which is necessary for adding new devices or fixing existing ones.

Thanks for the answer. I have only been buying thermostats since July. I bought three Saswell Wifi thermostats. I’ve tried getting them to work on Homey with Saswell’s own and Smart-E apps, but I can’t get them to install on Homey with either. I don’t understand what I’m doing wrong. I can see them in both programs (Saswell and Smart-E), but I can’t install them in Homey. Could someone give such a simple instruction that I would understand what is wrong with the installation.

thermostats are SAS921FHL-7W-WIFI (not SAS920FHL-7W-WIFI). Could that be the reason?

I cant say for sure, since I don’t own that devices myself.
Though, as long as your devices uses the Thermostat app from Saswell and are the thermostats for heating foils/mat, they should work.

I know there’s some thermostats for water floor heaters, that I yet have looked into…

I’m not aware that the Smart-E app is still functional, since the Scinan API is still offline…
Did you create an account using your email and paired your devices over the internet or are you using them with Smart-E on “Direct Connect”?
In order to use the Homey app, your devices needs to be available over the internet.

Please try to create an account with Thermostat and follow the instructions in the app to add them…
iOS: Thermostat on the App Store (apple.com)
Android: Thermostat - Apps on Google Play

heres a link to the manual of your device…
The manual says:
SAS920FHL\SAS921FHL systems thermostat for floor heating
so I guess it works just as 920 :slight_smile:

and heres an instruction on how to pair it to Thermostat app
the pictures is outdated, but the instructions seems solid.

go to the section that says

Saswell application APP – Installation, use – Step by step


after you done this you should be able to find your devices in my app :slight_smile:

The problem is not the Homey mobile app. The problem is somewhere in the thermostat application, wifi router or Saswell cloud service. When I install the Saswell thermostat on a wifi network, it does not go through successfully. The wifi icon on the thermostat keeps flashing and the Saswell mobile app claims it is offline. the network is 2.4Ghz and judging from the router, the thermostat has received an ip number. What could be the problem?

Hard to say without seeing everything.
But out of the information you’ve provided.
I’ll make some guesses :slight_smile:

  • The Wifi icon keeps flashing (11 on the picture)

  • the router has given it an IP-address
    (i’m also guessing you can Ping your device from Terminal/Command) using “ping ”

  • the network is 2.4Ghz

  • your device appears offline in Thermostat app

My guess then is that your device is indeed connected to your router but can’t communicate with Saswell cloud servers.

You could try to remove the device, reset it and try to add it again from scratch, maybe some settings didn’t follow through?

I see you are using iOS, I had some issues my first time to add my devices because of VPN messing up the devices transfer from AP mode to WiFi mode…

also try disable any VPN and Killswitch or Private WiFi address on your iPhone…
ensure that your phone is not trying to reconnect to internet by switching back to your wifi while connected directly to the device during pairing.

You could also try moving your device closer to your router. the eliminate weak signal as the reason.

Does it work better on an Android phone? I could test.

I have no idea.
But give it a shot, why not if you can :slight_smile:

what’s important is to ensure that your device gets connected to the cloud, when that is done. My app should work :wink:

Same problem with android phone. Indicates “Device already exists” during installation and the thermostat remains offline. the wifi icon remains flashing on the thermostat.

It doesn’t help even if the thermostat is next to the router during installation. Even removing the thermostat from the phone app and resetting the thermostat doesn’t help.

I put a query on Saswell (again). I hope they answer sometime.

You are saying it indicates that device already exist…. Did you remove it from the thermostat app before trying to add it again?

I have the same issue “Device already exist” is shown several times when trying to add it to the Thermostat app, it then failes but the device name (ssid name) is then listed, but offline. trying to toggle it online show the message “Thermostat is offline! Get the status failed!”
Exiting the app + login again and it’s still in the list.
Removing it + re-adding gives the same “Device already exist”-message.
Android app version 6.2.1
(I can access the device in “Direct”-mode)

sound like something that Saswell customer service need to look into… :man_shrugging:

you could try the APK found in saswells own website. its for an older version but, as long as the unit connects sucessfull to the cloud, it should work with my app :slight_smile:


Saswell website apk not working. Saswell does not respond to any query :frowning:

(You have to believe me here and stop trying) - Saswell pulled the plug on the servers. Your 921 wifi errors are server related. They have no plans to repair/reactivare the servers. For them these thermostats are to old, apps are problematic and they focus to migrate/develop for Tuya…