[APP][Pro] Samsung SmartTV

@balmli & @Emil_Linder I’ve also got a couple of Frames with Art mode, I too would love for it to go to art mode - like the remote on/off. Rather then a ‘hard off’. Happy to donate if that would help, also i’m quite comfortable with homey code and would be happy to help test/debug once I get my Homey back.

Since a couple of days i can only turn the tv on by homey. After that i can controle nothing. I heave allready done a PTP, restart the app. When i test a flow i get een orange notification “Operation failed(Error: connect econnrefused ïp adress tv”:8001

Check the IP for the TV… you can update the IP address from Adv. settings.

I recommend using a static IP address for the TV.

I heave the correct IP adress (turn on the tv by homey works)

i think i did someting wrong with te ip adress… my bad, sorry

Hi @Jamie @Emil_Linder

Have you tried the Send key POWER - action ?

Do you have “Frame TV support” = “Yes” in Adv. settings ? And does turning the TV off work ?

I don’t have a Frame TV myself, but I think that switching between normal and “art mode” is just sending the POWER - key…

Hello! Is there a way for you to add Samsung soundbar aswell? I’m Considering buying a HW-N950… This soundbar is using almost the same remote as my Samsung 55NU8000 TV…

Yes, if I use the feature ”send key” and command “power toggle” the Tv switches between on and artmode, but unfortunately it can’t understand the current state, so its hard to do automations.

When I look into samsungs SmartThings app in the phone, then I can see the Tv’s current state, so it should be possible to query the Tv for that. So if that feature would be possible to add then it would be great. :slight_smile:

The standard power command turns the Tv off unfortunately, and if I switch off “frame support” it did sometimes toggle between art mode and on, but at a later time it didn’t work, so to send the power toggle command is more reliable :blush:

I’m still having problems whith my TV. IP adress is correct and i can turn on the tv by homey, also starting Netflix works via homey. But thats all, torning the tc off is not possible (whith the toggle command AND the off command)

fore a long time it works great but since a couple of days it won’t work anymore.

Have you check if “Secure connection” is Yes in Advanced settings for the Samsung - device ?

I’m working on a flow set to connect alexa to Homey via the smarttv app and ONE virtual device.

Features: on, off, channel switch, start/stop different tv apps. At this time it works very well.

To stop a tv app the KEY_EXIT is the best solution. The key is missing in 1.6. But we talked about that on Github already and you will add it in 1.6.1. Thanks again.

But before I put more efford in the flow set is there an option to integrate the smarttv app in alexa directly without a virtual device?

It just got released to the store.

Yesterday i checked everyting when i came home late. Secure connection is YES.

Thanks @balmi for adding the KEY_EXIT and the quit response!

I think i made a mistake, this morning i checked te secure setting again and it sty’s OFF. I don’t no why but i set it back to YES again and everyting works back again. Sorry voor my mistake and thanks for your replay. And ofcourse the goog work on this great app.

1 Like

Hi balmli,
I tried to launch the browser on the TV with a flow, it works but it ignores the URL which I transfered. Do you know what could be the reason of this problem?



The format of the URL must be correct.
And your TV must support it.
What TV-model do you have ?


TV-Model is KS8090.

What is the correct URL format?

Any quotes? Can you give an example, please.


Just a normal URL, like this: https://www.google.com/

It should work on your KS - model.

thanks for the app. You did a great job.

unfortunatly it is not working for me to turn the tv on. in the topic you say that you need either WOL or WIFI, but if I put my tv on wifi modus it don’t work. I don’t have WOL.
if I use the [http://192.168.X.XX:8001/api/v2/ or http://192.168.x.xx:8001/ms/1.0/ I get a response with the details.

I also have installed the tv in homey several times but no luck unfortunatly. I have a UE75HU7500 and I saw that another user had the same model and it works he said.
Can you help me?