[APP][Pro] Samsung SmartTV

Your right regarding to a normal URL. The reason for my question was that I wanted to stream my ip cam via the samsung TV buidin browser. But the samsung browser isn’t able to connect with a user/password URL without a login windows.

So I use a chromcast with homey and your app for this now. Works fine.

Is it possible to switch the source from HDMI (im my case chromecast) to TV in a directer way than sending a key sequence (source , left, enter = TV is left from the chromecast HDMI port)? I played around but couldn’t find a solution.

I have an icon LiveTV configured in the smart hub. It looks like an app but isn’t included in the app tags to launch via a flow.


For a HU-model you should use the Samsung (encrypted) versjon. But I’m not sure if WOL / Wake-on-wan (wifi) works with your HU-model.

Some people cast something to a Chromecast to turn on their TV.

Switch source by sending multiple KEY_HDMI, or for some models the KEY_HDMI1, KEY_HDMI2 etc works.

You can send a list of keys faster by using the action: KEY_HDMI,KEY_LEFT,KEY_ENTER .(or something like that…)

I tried the list key function but the input is to fast for tizen. I know that I could expand the delay between the keys but that is not really the problem.

I’m using cable tv, so the tv function isn’t connected with HDMI. Is it possible to switch the source from HDMI (chromecast) to cable tv input with a direct command without the source , left, enter chain?

Commands like TV or TV mode doesn’t work when I try to switch from HDMI to TV.


Sorry, I don’t know… I think the most of the possible KEY-kodes have been added… so you’ll have to test …

Hi, I am using the encrypted version. So probably it is not possible.


i‘m not able to switch on channel 89 on dvb-t?

Could someone help?

Kindly regards


nobody can help?

the tv powers on correctly, but i can’t swicth to channel 89 on DVB-T (DTV Antenna).

best regards

Hello, thank you for this great app. On my Samsung NU8009 65" model year 2018 the homey app works only in rare cases. Message: Something went wrong please try again. Url works on my tv.

Hi Philipp,

Are you able to do other things? Like changing the volume etc. ?

Hi Dominik,

Can you check Advanced settings… that the IP-adress is OK.
And check the “Secure connection” - settings. Is it Yes or No ?

Hey! Thanks for quick reply!

Yes IP is ok and I configured in Fritz!Box WLAN Router, that the samsung TV always get the same local ip.

Default after connect device is “No”. I also tried to change this setting to “yes” and save this. After a few seconds on samsung I get tv several messages if I want to accept homey. I accept all three messages and homey is listed under authorized devices list as well. But if I check the setting after this, secure connection is disabled again. I tried to deactivate IPv6 and also change the setting “show message on new connected devices” to no. But this doesn’t help. I was wondering that when I try to activate secure connection again after this setting changes, the messages from homey (want to accept device) appeared again.

  "device": {
    "FrameTVSupport": "false",
    "GamePadSupport": "true",
    "ImeSyncedSupport": "true",
    "OS": "Tizen",
    "TokenAuthSupport": "true",
    "VoiceSupport": "true",
    "countryCode": "DE",
    "description": "Samsung DTV RCR",
    "developerIP": "",
    "developerMode": "0",
    "ip": "",
    "model": "18_KANTM2_UHD",
    "modelName": "UE65NU8009",
    "name": "[TV] Samsung TV 65",
    "networkType": "wireless",
    "resolution": "3840x2160",
    "type": "Samsung SmartTV",
  "isSupport": "{\"DMP_DRM_PLAYREADY\":\"false\",\"DMP_DRM_WIDEVINE\":\"false\",\"DMP_available\":\"true\",\"EDEN_available\":\"true\",\"FrameTVSupport\":\"false\",\"ImeSyncedSupport\":\"true\",\"TokenAuthSupport\":\"true\",\"remote_available\":\"true\",\"remote_fourDirections\":\"true\",\"remote_touchPad\":\"true\",\"remote_voiceControl\":\"true\"}\n",
  "name": "[TV] Samsung TV 65",
  "remote": "1.0",
  "type": "Samsung SmartTV",
  "uri": "",
  "version": "2.0.25"

For example (tried to reduce volume - tv on):

When you change the “Secure connection” to “Yes”, you must remember to save the changes by pressing the check mark in the upper right corner. Otherwise the settings won’t be stored in Homey.

Did you do that ?

hello, i‘m able to power on, then i‘m not able to change volume:



i have the same problems like dominik :frowning:

Change to “secure connection” in Advanced settings.

Remember to save the changes by pressing the check mark in upper right corner.

That will solve the issue I think

1 Like

The first time I tried it, this was the mistake, but I checked how it works right before I post here :slight_smile:. I tried today to reinstall the app and device. Now secure connection was a few hours on, but same problems. Now I see it is disabled again.


Something with the pairing process that is necessary for the secure connection that fails then.

Can you press the “create diagnostics report” button from Settings -> Apps -> Samsung SmartTV app … and I will get a log … and might be able to fix the problem.

What I want to emphasize once again is that it often doesn’t work for me, but sometimes it works smoothly. Now I just turned down the volume, turn off the TV - both works fine. But power on again acknowledged with an error message. However I could turn it on via Samsung Smart Things app. But not with the Homey app.

I send you the code via PN. Thank you!


wirh secure cinnection it works.

I‘m able to change channel, but i‘m not able to change the signal bevor from dvb-s to dvb-t, could someone say me the right key?
what is the key to set the volume to 10?
best regards