[APP][Pro] Samsung SmartTV

I have been using this app for a long time, but in the past weeks it lost connection to my TV. I tested the following methods to get it back, but no success.
*Removed the tv from the app
*Tested to add it, no tv found in all 3 options.
*Reinstalled app
*Gave tv a new ip on lan

The tv is working fine with Home Assistant, but the app doesn’t find it and will not find it via IP.

Edit: If anyone has Unifi network, enable Multicast enhancement. This solved if for me

1 Like

Since today i keep getting the message request for auth for Homey.

When i check the device list i see a ton of homey devices.

Anybody had this?

Just installed the pro 2023 and adder my Samsung tv.
I can use it in flows and start apps with a flow. But i miss the “canal digitaal” app in the list of apps.
How can i add it?

Already made a smart things api key at Samsung and entered it in the homey app. But still don’t see the app.

I noticed that after the last update it seemed to work (for 1 day) I have a flow running now that restarts my homey daily that I added about a week ago and it seems to work fine now… not sure why though

Is this just me or this app is not stable?

The TVs are sometimes displayed off but they are on, restarting the app can fix that temporarily. Etc…

What are your feedbacks? (Status reliability).

1 Like

I have the same issue sins i migrated to HP23, i have the app to restart every 5 min, to have a status if the tv is on or off.

1 Like

I got the same problem…

Same effect

The same problem.

Hi. I have a Samsung Smart TV from 2021 that won’t show actions in the Homey app. It used to work earlier, but now it don’t. How do I go further to get this to work?

Thanks for the app, great stuff!
I have a small issue with my 65S90 though,
I am able to control the features in the app, when I turn it on the correct state is represented.

I noticed when creating a flow on power off this state is not correctly represented. when the display is turned off using the remote it stays on the on state in my homey dash.

Maybe its me and I’m using the wrong settings, please help :slight_smile:

Hi, It’s a great app and it worked fine on my Pro2019, but now somehow I get an error when switching HDMI source:
Changing input source failed: invalid device state (409 Conflict).

What Google says about 409:
A 409 status code is used to indicate a conflict with the current state of a resource, such as when trying to create or update a resource that already exists or has conflicting information. This status code indicates that the request cannot be completed due to a conflict with the current state of the resource.

I don’t know what causes it and how to fix it.
Removed TV from App, Removed App.
Created new API token (all permissions and options), reinstalled App, added TV again, but the error persists.

Any thoughts how to solve this?

I have the same behaviour on my TV. Did you figure it out?

@Riccardo yes, disabled the polling

Thanks for the feedback. Disabling Power state polling means I won’t know when TV turns on, right? Shame, was using it as a trigger to turn on some lights.

1 Like

@Riccardo yes :confused:

Disabled polling. Same notification and changing source still fails.

I like the way you van switch apps, but for some reason plex does not work, is there an easy fix for that?

I can turn off the TV but not turn it on.
I can operate the volume with the buttons, but can not send a value.
In addition, I can not check if the TV is on. It always reports on to me (because ON in the app).
How can I fix this?

Anyone an idea?

http://IP:8001/api/v2/ is working…