[APP][Pro] Samsung SmartTV

I am having the same issue. I would like to set the “Source Input” to “Live TV (Kabel)”, before changing channels with a flow, but the “Source Input” list is empty.

Do I even need to use “Source Input” to switch my TV to “Live TV (Kabel)”?

EDIT: Found my solution! I can use the “Send key” card and use “TV” as the key.

New version, v. 2.0.0, is now ready for testing!

  • The pairing process for all drivers (Samsung, Samsung encrypted, Samsung legacy) has been updated
  • Users of the Samsung (encrypted) devices might need to re-pair

Please test :slight_smile:

1 Like

Installing it on the Black Puck now.

I have just installed it on the 2023, and created a device (samsung 8 series 55).
It was created correctly.
After creation, it still showed a volume slider, moving it made the app/driver crash. After it restarted, the slider was gone (correctly).

Other buttons work, but in flows, send key doesn’t show any keys in the list.
Okay, select-list (as flow arguments) don’t seem to work correct on the new/beta Homey App 7.0.

Your TV Smart App seems to work correct in the Web App on the Homey Pro 2023!

1 Like

Thanks for testing, @Arie_J_Godschalk
So there’s an issue with the slider. Will have a look at that.

1 Like

Well, the slider should not be there for my device (because i use external audio).
But, i have a small feeling i just was to fast for the app to remove the slider.

Do you have anythink in you app that, during runtime, after creation, updates the capabilities and hiddes the volume slider if the TV doesn’t currently support percentage/slider?

Yes, the app checks if the TV responds to UPnP requests, to be able to set the volume directly. If not the slider is removed.

1 Like

Then, could be that i was to fast in sliding after creation. I wouldn’t spend to much time on it.

1 Like

New version, v. 2.1.0, is now ready for testing!

  • Added action to close a running app
  • Adjustments to the SmartThings API client.

Please test :slight_smile:

1 Like

Is there anyway to send “TV pause” to homey from tv?

No, right now there isn’t

Nice to have this Samsung SmartTv app. Mostly it works. I have added the API key, but still I don’t see the option to change input source.
The slider is visible in my Homey, but it doesn’t work.
Does anybody have suggestions?
To the maker: do you intend do add more buttons/options/settings? Or are you mainly limited by the API capabilities?

Here is the result from the TV api URL:

    "device": {
        "FrameTVSupport": "false",
        "GamePadSupport": "true",
        "ImeSyncedSupport": "true",
        "Language": "nl_NL",
        "OS": "Tizen",
        "PowerState": "on",
        "TokenAuthSupport": "true",
        "VoiceSupport": "false",
        "WallScreenRatio": "0",
        "WallService": "false",
        "countryCode": "NL",
        "description": "Samsung DTV RCR",
        "developerIP": "",
        "developerMode": "0",
        "duid": "uuid:312ada96-17c7-4b0e-bc10-ff611867c964",
        "firmwareVersion": "Unknown",
        "id": "uuid:312ada96-17c7-4b0e-bc10-ff611867c964",
        "ip": "",
        "model": "19_MUSEL_UHD_BASIC",
        "modelName": "UE50RU7100WXXN",
        "name": "[TV] Televisie",
        "networkType": "wireless",
        "resolution": "3840x2160",
        "smartHubAgreement": "true",
        "ssid": "b0:a7:b9:ba:d9:02",
        "type": "Samsung SmartTV",
        "udn": "uuid:312ada96-17c7-4b0e-bc10-ff611867c964",
        "wifiMac": "00:C3:F4:E2:48:8C"
    "id": "uuid:312ada96-17c7-4b0e-bc10-ff611867c964",
    "isSupport": "{\"DMP_DRM_PLAYREADY\":\"false\",\"DMP_DRM_WIDEVINE\":\"false\",\"DMP_available\":\"true\",\"EDEN_available\":\"true\",\"FrameTVSupport\":\"false\",\"ImeSyncedSupport\":\"true\",\"TokenAuthSupport\":\"true\",\"remote_available\":\"true\",\"remote_fourDirections\":\"true\",\"remote_touchPad\":\"true\",\"remote_voiceControl\":\"false\"}\n",
    "name": "[TV] Televisie",
    "remote": "1.0",
    "type": "Samsung SmartTV",
    "uri": "",
    "version": "2.0.25"

After updating to the new version the smart things api doesn’t work properly anymore I guess.
I’m having the same issues like you.
Prior to the update everything was working well but after the update I can’t see any sources anymore.
Even getting a new api etc didn’t work.
I hope there will be a fix for that soon.

The smart things api doesn’t work properly anymore. Prior to the update the source selection did work well. Now I can’t see any source anymore.

Can you create a diagnostics report ?

not sure if other people also have the same issue, but since the last update my homey doesn’t detect on/off anymore. i already try removing/pairing again that fixed the issue for a day or so.

created a diagnostic report for it (not sure if it helps) d0eafab3-b848-4d8b-96a7-4e4bca3a7126


This is the code for the source input selection problem.

Looks like there’s something wrong with your SmartThings token. Try creating a new one.

[log] 2023-03-11 14:58:14 [ManagerDrivers] [Driver:Samsung] [Device:521b9fed-d744-4a25-b1d1-678830a2d912] [Info] getStInputSources failed Error: The API token must be set correctly.
    at SmartThingsClientImpl.fetchSmartThingsDevices (/lib/SmartThings.js:60:19)

Can you try creating a new flow for the on / off - trigger ?

I tried a couple of new tokens but it’s still not working. I created a PAT (Personal Access Token) at https://account.smartthings.com/tokens and used the generated key. But it’s still not working.

Any other suggestions? Or is it possible to reinstall the older App Version?