[APP][Pro] Philips Hue Extensions [Abandoned]

As I am super unhappy with athom (and @Emile in person) I decided to stop any work on this app and removed it from the store. Sorry folks, if you wan’t to disuss this you can do so with athom, I won’t be available for any homey related support.


The app crashed when i install it.

Sorry to hear that, could you provide me the log?

I have the same problem as Wesley_Witjes. When the app is installed it crashes. Ans when I get to the configuration page it keeps on infinitely loading.

2020-05-16 08:46:39 [log] [HueExtensionsApp] HueExtensionsApp is running...
			Homey.ManagerSettings.on('set', this.onSettingsChanged.bind(this));

TypeError: Cannot read property 'bind' of undefined
    at HueExtensionsApp.onInit (/app.js:15:59)
    at fs.stat.e (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/lib/SDK.js:1:3885)
    at FSReqWrap.oncomplete (fs.js:153:5)

--- INFO: ch.philippewechsler.hue has been killed ---

I think I solved it, please checkout v1.0.1

1 Like

The app ask me for an api key? where can I get this

solved :slight_smile:

Nice app for the community App Store: Homey Community App Store


It is allready in the community store😀

1 Like

v1.1.0 is out!

Pressing discover and authenticate, it shows the IP but no prompt or anything to connect the hue bridge. Tried pressing the hue bridge button after that and rediscovering doesn’t set anything. Hitting save also ask for an API… what now?

Same here , cant configure the app. Need api key.:thinking::thinking:


And how did it solved ? Because ive got the same “problem”

It is inteded to work like this:

  1. click on authenticate
  2. the ip should have been discovered and there appears a green message saying that you now should press the button and again click authenticate again
  3. the app key should be retrieved and you get a success message.

As I understand you step 1 is only partially sucessfully, in detail you get the ip but not the green message?
Can you please check that the ip is actually correct and that homey and the bridge are in the same network?

Thks for the response, they on the same network. It discover the ip , wich is correct. But i dont get the message , to press the button on the hue bridge.

Already did a PTP no difference.

Can i fil in the api key myself? And if so where could i find it.

I need to investigate what happens here, might some time as I am quiet busy right now.

But of course you can retrive the key manually, see the official documentation for details: https://developers.meethue.com/develop/get-started-2/

Dont rush, it your freetime so…

Getting the api key with the link you given is easy, it accepted the key and can do stuff with the api debug tool.

But in your app only can select “all lights” no groups or individuel lights. So gonna play again later in the weekend, otherwise i wait till you maybe found something in your app.

Till that thkss and enjoy your weekend.

Yes my experience is the same @RoyWissenburg.
The hue bridge IP is correct and on the same network. Will add the key manually too. Not sure why it doesn’t show the prompt too.

Ook bij mij is het gelukt het ip adres en api code in te stellen. Echter kan hij ook geen groepen of losse lampen vinden. Ik kan helaas ook niet vinden hoe ik deze in de app kan aanmaken. Ook de groepen uit de Groep app van Homey herkend hij niet. Hoor het graag. Lijkt me een geweldige aanvulling!