[APP][Pro] OctoPrint

If the finish line wasn’t a massive wall called “available time”, I could have “finished” :see_no_evil:.

1 Like

OK, so I actually thought of a (very/too) easy way to fully “fix” the breaking changes in my fork. :sweat_smile:
Almost embarrassing that I didn’t thought of it before/immediatly.

So instead of just deleting the old capabilities, i’ll just hide them from your current device (tokens will remain active!, and still update their values), and new included devices just won’t have these (old) capabilities anymore (kinda a custom interpretation of deprecating a capability).

The update is now live on my github now (v1.1.1), and I’ll update my original post above.
Breaking free updating!

1 Like

Strange thing, i installed the plugin ans got it working. But when the IP changed on the PI i got dissconnected. So i changed the PI to always have the same IP, but now im unable to install the plugin. Get the flowtoken_already_exists after added the OctoPrint to the Homey. Could someone help me please?

Try rebooting Homey, that should fix the stuck flowtoken id’s of the old device.

hah, it was that simple :slight_smile:

I tried to add my octopi but always get and timeout, i tried with local ip and with local domain :confused: any advice?

Instal eg. NetScan to see if Homey really can access your OctoPi

1 Like

thank you for the advice, netscan works liek a charm with the octopi

#edit
now it works, dont know why because i justed tested with netscan and after that adding was not a problem…

Hi all

I seem to get stuck in the basics here. I am trying to add OctoPrint as a device over my browser, but I keep on getting the message: “Could not connect to OctoPrint. Make sure your address and API key is correct.”

I do enter the IP address and the API key but it won’t work. I tried including the ports to the IP, but did not work either. I’m certain that Homey and OctoPrint are in the same network and both are online since I can see them in the list of the devices connected via Wifi to my router.

I can connect through the OctoRemote app, so it’s likely something wrong on how I provide the address and API key?!

Any idea what I’m doing wrong?

Thanks

Just to be sure, you are using the version from Caseda, right ?