[APP][Pro] Nuki Direct

I’d like to install Nuki Direct to my Homey but the Install button is greyed out. Is there anything special I need to do to get it installed? I’ve tried to search for Community Store in teh official Homey App Store but can’t find that either.
Thanks for your help

not that I know. the app asks for the bridge and if you set your ip to a fixed ip, you can then find and install the locks. what and where is the gray area ? do you have an opener or a lock ?

I have a lock and the install button is greyed out (see attached). The question is: how/were do I access the community shop? If I search for the shop in my Homey by add new device, it doesn’t show up. Is there a special access/trick needed to acces that shop?
Right now I access the shop witgh my web browser

First you have to install the installer on your PC or Mac:

It’s a complete Athom independent community store.

Hi Peter
and hiw can I access it? Sorry, I struggle with that. If I open it in my web browser I can access teh store but the install buttons are greyewd out. What do I do wrong?

Atm it only seems to work using Firefox browser on a laptop / pc.
The link was povided above here, by Fantross but here you go

You’ll find installers to install the store app on Homey (for Windows, Mac & linux).

If that went well, you’ll find Homey Community Store between your app overview.

Now you’ll have to logon to the store.
Look for “Profile” on the left menu, and follow instructions carefully.
When logged on, the app install buttons are green.

OK, cool , I will try that. Many thanks Peter

1 Like

YW! Installing the apps after this one is a bit easier. Just be logged on, pick an app and install it.

Thanks both, now it works perfect and I’ve already installed Nuki Direct


Hi @Piero_F,

does the app support the new Nuki Smart Lock 3.0 Pro with built-in bridge?

Thx in advance!

1 Like

Hello @fantross,
In order to answer your interesting question, yesterday I read the Nuki updated technical documentation.
The straight answer is no, the current version of Nuki Direct app is not able to work with Nuki Smart Lock 3.0. However, I think some code changes should allow the app to work with the latest Nuki devices.
I do not own a Nuki Smart Lock 3.0. What I can do is release a new version of the app which will definitely continue to work with Smart Lock 2.0 and which, maybe, will work with Smart Lock 3.0.
If you do own a Smart Lock 3.0 and you are available giving feedback on the app behavior, maybe we can tune the app also for Smart Lock 3.0.
Best Regards

1 Like

Thank you for your detailed feedback and willingness to modify the app.
Because the Nuki Smart Lock 3.0 Pro is actually not flawless supported by the Athom Nuki app, I haven’t bought one yet. If I buy one, I will let you know and of course I would test the app.

Many thanks in advance!

Hello all,

I’m quite nee to homey but i’m getting there.

I want to buy a NUKI smart lock 3 (front door), does it already work with homey?

Either the DIRECT or ATHOM app.

Appreciate your work!

The Nuki Smart Lock 3 is only supported by the Nuki App from Athom. But I don’t know if it works properly.
I hope @Piero_F will add the Smart Lock 3/Pro also to his app, because my Nuki Smart Lock 3 Pro is on the way to me. :wink:

1 Like

Hi, Smart Lock 3 Added:

Testing by cli


Dear all, maybe some of you can help me out, I cant add new NUKI devices:

After installing NUKI direct I configured the Bridge as described and tried to add a new device by using the Nuki direct app. The App wants me to push the button on the Bridge which is recognised but then it shows the message “No new devices found”.
NUKI SmartLocks are definitely connected to the Bridge and API is enabled.

I already tried
-) uninstall the original Nuki App.
-) re install Nuki direct
-) factory reset of nuki bridge (and enable HTTP API)

What am I doing wrong?
Thank you in advance and best regards

Hi, which nuki do you have? If you have the smart lock 3.0. try using my fork with the homey cli Getting Started - Homey Apps SDK

Hi @DominicVonk

I tried to install the nuki direct app via cli method but received this message:

✓ Validating app...
✖ App did not validate against level `debug`:
Found multiple Flow card triggers with the id "nuki_state_changed", all Flow cards should have a unique id.

Did you download the last version from my git repository?