[APP][Pro] Mill Heating

You still need to migrate. Migration has nothing to do with Homey, it’s Mill that is doing the migrating to a new platform (I guess). You should be migrating using the Mill-app or here.

Thanks. Now its working

1 Like


Hmm. Weird… Can you create a diagnostics report? :slight_smile:


Still getting this message, but the app debug monitor looks good, and I have tried too intergred them into tibber and that works, is not what I want just a test, so I can remove them from tibber, If that make trouble for your app👍

Apparently the new app generates a large number of requests to the Mill server. Although the allowable number of requests has been increased, I still experience that the limit is exceeded early in the day, and that I am not able to do anything till the next day. When will this be fixed?
I have 8 Mill units, and also a Tibber app that accesses the Mill server.

That makes sense, incredibel a lot of request to the Mill server, maybe therefore I can,t connect my 2 mill heaters and I got 4 more to connect

I had to turn off the individual mode to get it to work - contrary to what is written in the documentation. Each unit is allocated to a room, and is in Comfort mode.

Ok, I will try that👍

@Alf_Pettersen @JanSten12
Thank you for your feedback! :blush:

Regrettably, when Mill updated their API, it appears they also altered the communication method between the API and the devices. This has led to issues with individual device control, contrary to what the documentation suggests. As @JanSten12 has highlighted, the current documentation is misleading. I haven’t updated it yet, but I will address this issue ASAP. :blush:

Can somebody show a flow that does something with the Mill heater. Nothing happens when I try. I have got “Migration finished”

Take away individual mode and get the heater a room, that works👍, sadly I could not transfer one heater to a specific room so I delete it in the Mill app, now I struggle to get it back to the wifi again, I think I have tried every thing, reset wifi, reset the heater and of cause use 2,4 mhz. I don,t really get it… I,m so disappointed over it, Norwegian stuff , and I,m from Norway. Why should that be so damn difficult, maybe someone have some tips. I have Generation 2 glass heater

I have contact Mill support, they will release an update with alternativ connection to wifi, like the old Mill app, hope it will work better when your in trouble to connect to wifi👍

1 Like

Hey, Thank you for the good work! I have successfully added all my Mill devices to the homey, and at first, I had some trouble being able to do anything, but after reading here, and setting them all to permanent comfort mode I was able to adjust the thermostats for all ovens. But after this first go, nothing works.

If I in the homey app enter one particular device and change the thermostat I get an error: "Cannot read properties of null(reading ‘modename’).

I have a total of 8 ovens, 3 different types all gen 2 or newer. Migration is done, every oven is in a “room” in the homey app. The mode is continuous comfort. I do get an error if I try to change the thermostat in the Mill app, Saying: “The function “control device individually” is activated. Would you like to turn off “Control device individually”?” This function is set by Homey or the Homey Mill app/integration, nothing I have set. Is it so that if I remove the individual control everything works? And is this a “permanent fix”?

One of my Mill device is offline in my HP2023. The other is online and they are the same model. How do I solve this problem?

Have you check it,s online in the original Mill app? I think the homey app just reflect what happen in the Mill app, just a guess

My Mill devices is no longer online in the Mill app after I ran the “Mill Heating Migration”. Now two of three Mill devices is online in HP2023 but I cannot figure out why the third is not

How do I add/delete/edit the Mill devices in HP2023?

I have

  • removed all my devices in the Millheat app on my mobile,
  • removed the Millheat app on my mobile,
  • removed all my devices in the HP2023 Mill Heating app,
  • removed the HP2023 Mill Heating app,
  • restarted HP2023,
  • installed the HP2023 Mill Heating app
    and I can still add my Mill devices to HP2023

My Mill devices are all offline in the android app. On an iPhone they are all online. And in the Tibber app they are offline. I can control them from Homey thou

I mean you have to install each heater in the original mill app and give each heater a «room» , then after add it to homey app and use away, sleep, comfort or program.
You say some works in homey but not in the original mill app, I have tried the same and it,s visual in homey but they are not working before the are implended in the original mill app. I know much trouble…
I,m not a programmer, but it seems that guy « coderax» is in the thinking box, Bless him for the good work he has done after Glenn👍