[App][Pro] LIFX (LAN)

Glad it is solved. Enjoy :slight_smile:

1 Like

Hi Shakesbeard,

I bought a new ubiquity access point and did a test with fade time! It works again. Thanks for the help!

1 Like

Is now live! Please welcome support for the LIFX Clean HEV Light features! :confetti_ball:

1 Like

Hi
I am suddenly unable to control any lifx lights anymore
They all said that it is unresponsive/offline…
Tried to del and reinstall the app but same thing happens.
I Tried to remove all devices and find new devices but cant find new devices as well…

Controlling of lights still works on lifx iphone app and works on lifx app by Homey as well, but not on Lifx (LAN) app

PLease help
I sent a Diagnostic report d0c3a3e5-9dcd-44f1-906b-1f05826fe4d9

THanks

Those are using the cloud api. This app here uses the LAN api to communicate with the LIFX devices.
I think I just responded to your report. If the Athom mailserver does not bounce it again.

For the LAN api to work your LIFX devices must be reachable by your Homey over the local network.
Possible causes for this not working could be:

  • You installed a firewall between Homey and the rest of your network without allowing the traffic required for this
  • You enabled something like device isolation in your wifi access point, that connects Homey and the LIFX devices
  • You set up some vLAN seperation and did not setup routing between vLANs for the LIFX protocol

Hello!
Have just setup my Homey Pro and connected it to lifx. For 3 of my 13 lifx units i got this error message “light_temperature outofrangeError xx is greater than y”
This works fine in the lixf app on my Iphone 12, it’s just in the homey app the error is shown.
This 3 units is all Mini c bulb. But one of my Mini c works fine.
Do you have some workaround for this?

Hi @Kalle_Barosen,
welcome to the forums!
I am not aware of any such issues so let’s dig in and find what causes this problem.
For this I need you to do 2 things.

  1. Reproduce the error with one of the lights and right afterwards generate me a diagnostics report for the app by going to Homey app menu “More…” → “Apps” → “LIFX LAN” → little gear icon → and hit the Generate Diagnostics Report button.
  2. Go to the menu “More…” → “Apps” → “LIFX LAN” → Go app settings and send me a screenshots or suitable copy of the device list at the bottom of the settings page. It is fine if the screenshot contains the 3 problem devices only. Please send it to me as direct message on the forum here.

I suspect that the devices have wrong values in the products catalogue or maybe their firmware is not up to date. But lets see.

Fast response :slight_smile:
I had downloaded the Lifx app i homey, not the Lifx LAN. Don’t know the difference between them… But when I run the LAN app everything works fine so i guess I should use that?

Well, the LIFX app is made by Athom themselves and uses the Cloud API of LIFX.
LIFX LAN is my app and relies on the local network protocol. So it also works if you internet goes poof :smiley:
It is a matter of preference really. But LIFX LAN for sure has more features ^^

Okey! Then I go for your app :slight_smile:
Good work!

Hi everyone,
I was able to successfully install the app and my lights get all detected, which is great.

However, I cannot get ‘Set scene’ command to work.
When I select this action as part of a flow, the menu where I am supposed to pick a scene from a dropdown returns an empty list.

In the app config I have inserted the api token, which I have freshly generated.

And afterwards I have saved the settings and restarted the app, to no avail. The scene list does not load!

Finally, I have alto restarted the homey pro, but not better results.

Is there a known bug I am not aware of?
Can anyone help me understand what I am doing wrong?

Thanks!

Hi Stefano,
welcome to the forums!
In fact, I do not think that you are doing anything wrong. It sounds about right what you did.
I just tested it and it seems to work for me. Maybe there is an issue which has not yet been detected.
Can you try to reproduce the empty list problem and send me a diag report right afterwards?
For the latter go menu “More…” → “Apps” → “LIFX LAN” → ‘little gear icon’ and hit Generate Diagnostics Report. I will try to see if I can make out any technical problems in the logs.

Thanks a lot, i have just generated the report and I suppose this gets sent to you automatically.

Again, great to get your perspective!

Regards

SV

Hi agin @Shakesbeard
I have 13 different lifx devices. But only 12 of them are showing in the Lifx Lan app on my Homey. When I look into the setting off the app I can se all 13. Do you have any idea why one is missing (Lifx Z ledlist)

You got a Diagnostic report

Well, if it is listed on the app settings page then LIFX LAN can see it.
Are you sure you did not pair it already? Or maybe missed to pair it? The App.Settings page also shows unpaired devices.
If it is not recognized by the LIFX Z filter in the pairing process try going for the ALL Devices option. It literally is the very same just without any filtering for the pairing view.

It’s so easy when you have the answer… :slight_smile:
I had forgot to add it… :see_no_evil: Sorry…
Thanks for fast respond and a great app!

1 Like